Foros del Web » Creando para Internet » Flash y Actionscript »

botones en un MC

Estas en el tema de botones en un MC en el foro de Flash y Actionscript en Foros del Web. Huolas....tengo una duda, un poco tonta.... me explico, tengo unos botones en un frame, con unas acciones asociadas. Pero necesito crear una interpolacion de movimiento ...
  #1 (permalink)  
Antiguo 09/05/2006, 17:48
 
Fecha de Ingreso: junio-2003
Mensajes: 203
Antigüedad: 14 años, 6 meses
Puntos: 0
botones en un MC

Huolas....tengo una duda, un poco tonta....

me explico, tengo unos botones en un frame, con unas acciones asociadas. Pero necesito crear una interpolacion de movimiento con ellos, para que vayan apareciendo en el escenario. El problema, es que cuando hago eso, los botones, dejan de funcionar, tal y como lo hacian antes.

He intentado crear un MC, con estos botones, y sus acciones, pero tampoco me funciona..... en teoria, deberia de funcionar, no??....o esto no es posible?...wenu a ver si alguien puede echarme una mano.....


muchas gracias.

Un saludo.
  #2 (permalink)  
Antiguo 09/05/2006, 18:30
Avatar de roc2107
ɹopɐɹǝpoɯ
 
Fecha de Ingreso: febrero-2003
Ubicación: León Guanajuato
Mensajes: 4.834
Antigüedad: 14 años, 9 meses
Puntos: 109
Qué acciones le pones a tus botones y en donde los pones, en una capa nueva o en el mismo fotograma donde estan tus interpolaciones???
__________________
Blog de Diseño Gráfico roc21.com || Exámenes

El secreto de la creatividad es saber esconder tus fuentes.
  #3 (permalink)  
Antiguo 09/05/2006, 18:47
Avatar de Prince  
Fecha de Ingreso: mayo-2003
Ubicación: DF
Mensajes: 574
Antigüedad: 14 años, 7 meses
Puntos: 1
Si en teoría debería funcionar, sólamente que hay un error que pasa muy seguido.
Sucede que las acciones para los botones las puedes poner en dos lugares, una línea de tiempo, o el mismo botón.

Ahora, para hacer una interpolación de movimiento se necesitan mínimo 2 frames, el del comienzo y el del final, por tanto, si las acciones se las pusiste directamente al boton, con un on(release) ... asegúrate que esas acciones estén tanto en el frame donde comienza la interpolación como en el frame donde termina.
En teoría nada más debería estar donde termina la animación para que funcionaran ya que terminara la interpolación.
__________________
- P R I N C E -
  #4 (permalink)  
Antiguo 10/05/2006, 11:17
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola juan_pele:
Para que siga funcionando el botón después de hacer una interpolación, primero debes de poner el código en el botón antes de crear la animación, de ese modo cuando crees el otro fotograma clave para la animación siempre mantendrá sus códigos.
Otra forma sería que el código lo pongas en el botón que está en el último frame de tu animación.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 12/05/2006, 06:52
 
Fecha de Ingreso: junio-2003
Mensajes: 203
Antigüedad: 14 años, 6 meses
Puntos: 0
Huolas...os cuento, las acciones estaban bien situadas....solo que....usaba el gotoandplay....con el numero de frame, y asi parece ser...que no funciona mu bien, unicamente les puse etiquetas a los frames, y listo. Ya funciona bien.

Muchas gracias por las respuestas.

UN saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:57.