Foros del Web » Creando para Internet » Flash y Actionscript »

Caracteres con acentos desaparecen

Estas en el tema de Caracteres con acentos desaparecen en el foro de Flash y Actionscript en Foros del Web. Buenas amigos, estoy llenando un campo de texto con una variable, y me pasa que los caracteres con acento directamente desaparecen! Un ejemplo de como ...
  #1 (permalink)  
Antiguo 30/11/2005, 11:35
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Caracteres con acentos desaparecen

Buenas amigos, estoy llenando un campo de texto con una variable, y me pasa que los caracteres con acento directamente desaparecen!

Un ejemplo de como completo el campo de texto:

Código PHP:

_root
.frase="téxtó cón ácéntós";

texto.text=_root.frase
Ya probé seleccionando caracteres latinos, etc. y también con System.useCodepage = true; pero sigue sin funcionar...

alguien sabe a que de debe esto????

Gracias anticipadas!
  #2 (permalink)  
Antiguo 30/11/2005, 12:00
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola miguellara:
Es raro lo que te pasa si estas usando un campo de texto con Var: frase y el código: _root.frase="téxtó cón ácéntós"; no es necesario adicionarle nada para que muestre los acentos.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 30/11/2005, 13:20
Avatar de H3r3j3  
Fecha de Ingreso: junio-2005
Ubicación: Where hope and daylight dies
Mensajes: 64
Antigüedad: 12 años, 5 meses
Puntos: 0
La mayoria de veces este problema ocurre por que no esta "embedida" la fuente... prueba seleccionando el campo de texto, y en el panel de propiedades puedes ver un boton que dice "Embed..." (uso la version en ingles, no se que diga la version en español), presiona ese boton y agrega los caracteres con acentos, ah! y tambien Ñ's (minusculas y mayusculas) y algun otro signo si lo necesitas

suerte
  #4 (permalink)  
Antiguo 30/11/2005, 14:15
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Bandit, H3r3j3 gracias por responder mi pregunta, si es bastante raro esto de los acentos ...

En mi version de Flash 7 MX Pro no tengo esta opción "embed", sí tengo la opción "Characters" y dentro el la posibilidad de seleccionar puntuación, etc, tengo seleccionado latin, puntuaciones, lowercase y uppercase pero no pasa nada!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:43.