Foros del Web » Creando para Internet » Flash y Actionscript »

cargado un moviclip dentro de otro, pero no se regresar a la escena principal

Estas en el tema de cargado un moviclip dentro de otro, pero no se regresar a la escena principal en el foro de Flash y Actionscript en Foros del Web. hola, he creado un clip de pelicula dentro de otro, y en este ultimo, lo que quisiese es que al pinchar sobre un boton pudiese ...
  #1 (permalink)  
Antiguo 16/01/2011, 20:52
 
Fecha de Ingreso: marzo-2008
Mensajes: 43
Antigüedad: 14 años, 3 meses
Puntos: 0
cargado un moviclip dentro de otro, pero no se regresar a la escena principal

hola, he creado un clip de pelicula dentro de otro, y en este ultimo, lo que quisiese
es que al pinchar sobre un boton pudiese volver a un frame del principal, como lo podria hacer, otra cosa si saco de la biblioteca un boton y lo pongo en esta escena seguna, no me funciona el movimiento del boton, he tenido que añadir un addchil para descargarlo. muchas gracias.
  #2 (permalink)  
Antiguo 17/01/2011, 02:31
 
Fecha de Ingreso: diciembre-2010
Ubicación: Madrid
Mensajes: 342
Antigüedad: 11 años, 6 meses
Puntos: 28
Respuesta: cargado un moviclip dentro de otro, pero no se regresar a la escena princi

A mí lo que mejor me ha funcionado para regresar al la escena principal es:
on (press){
_parent.gotoAndPlay(1)
}
(1) sería si quieres regresar al principio de tu película, pero si por ejemplo quires ir al fotograma 30, cambia (1) por (30)
  #3 (permalink)  
Antiguo 17/01/2011, 09:07
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 19 años
Puntos: 406
Respuesta: cargado un moviclip dentro de otro, pero no se regresar a la escena princi

Hola andykofman:
Para ir a un frame de la Línea de tiempo principal desde un MC anidado dentro de otro, el código debes de escribirlo así:
Código actionscript:
Ver original
  1. on(release){
  2. _root.gotoAndPlay(numero_frame);
  3. }
Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/

Última edición por Bandit; 21/01/2011 a las 15:01
  #4 (permalink)  
Antiguo 21/01/2011, 07:31
 
Fecha de Ingreso: marzo-2008
Mensajes: 43
Antigüedad: 14 años, 3 meses
Puntos: 0
Respuesta: cargado un moviclip dentro de otro, pero no se regresar a la escena princi

muchas gracias por contestar, pero no me funciona, he hecho lo que dices y me pone un error 1086, que se SE ESPERABA PUNTO Y COM despues de o en leftbrace, a
muchas gracias
  #5 (permalink)  
Antiguo 21/01/2011, 08:36
Avatar de Mahalo  
Fecha de Ingreso: julio-2004
Ubicación: Mallorca (Illes Balears)
Mensajes: 1.121
Antigüedad: 18 años
Puntos: 12
Respuesta: cargado un moviclip dentro de otro, pero no se regresar a la escena princi

Bueno, Bandit cometió un pequeño fallo que fue poner dos puntos en vez de punto y coma (las teclas están juntas en el teclado), te lo dice el mismo error. El delimitador de código en as es el punto y coma. Siempre hay que ponerlo al acabar una instrucción.
__________________
Los ignorantes se empeñan en enseñar. Los sabios en aprender.
SourceForge

Etiquetas: escena, principal, regresar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:50.