Foros del Web » Creando para Internet » Flash y Actionscript »

cargador usado dos veces no funciona

Estas en el tema de cargador usado dos veces no funciona en el foro de Flash y Actionscript en Foros del Web. Saludos, solo una pregunta, yo engo un cargador, con el codigo que esta al final de este post. asi mismo tengo dificultad si lo quiero ...
  #1 (permalink)  
Antiguo 30/05/2007, 13:25
Avatar de mau.  
Fecha de Ingreso: octubre-2004
Ubicación: El Salvador, Santa Ana
Mensajes: 1.879
Antigüedad: 13 años, 1 mes
Puntos: 5
Exclamación cargador usado dos veces no funciona

Saludos,
solo una pregunta,
yo engo un cargador, con el codigo que esta al final de este post.
asi mismo tengo dificultad si lo quiero usar dos veces ,
la primera vez lo uso en el cargador inicil del website, pero la segunda vez lo necesito usar para cargar con LOADMOVIE un swf,
y se queda trabado.
osea que en un segundo swf no puede ir este codigo por que ?
como puedo modificarlo para que funcione con load movie y que el movie que cargue pueda tener el mismo cargador .

desde ya gracias.
saludos
necesito ayuda porfa.

-----------------------
onClipEvent (load) {
total = _root.getBytesTotal();
}
onClipEvent (enterFrame) {
loaded = _root.getBytesLoaded();
percent = int(loaded/total*100);
text = ""+percent+"%";
gotoAndStop(percent);
if (loaded == total) {
_root.gotoAndPlay("cuerpo");
}
// end if
}
------------------------
__________________
Este es mi nuevo portafolio www.elsalvadorguia.com
  #2 (permalink)  
Antiguo 30/05/2007, 14:33
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
Re: cargador usado dos veces no funciona

Prueba a poner este código en el segundo mc que cargas:

onClipEvent (load) {
total = this.getBytesTotal();
}
onClipEvent (enterFrame) {
loaded = this.getBytesLoaded();
percent = int(loaded/total*100);
text = ""+percent+"%";
gotoAndStop(percent);
if (loaded == total) {
this.gotoAndPlay("cuerpo");
}
// end if
}

A ver si es eso...
Saludos

Última edición por osiris; 30/05/2007 a las 14:34 Razón: concretar más
  #3 (permalink)  
Antiguo 30/05/2007, 14:58
Avatar de mau.  
Fecha de Ingreso: octubre-2004
Ubicación: El Salvador, Santa Ana
Mensajes: 1.879
Antigüedad: 13 años, 1 mes
Puntos: 5
Exclamación Re: cargador usado dos veces no funciona

sorry !!!!!
no funciona se queda igual que la primera prueba
dejo aqui la direccion.

el cual lo notaran despues de el segundo boton CONTINUAR.
saludos
__________________
Este es mi nuevo portafolio www.elsalvadorguia.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:05.