Foros del Web » Creando para Internet » Flash y Actionscript »

Cargando swf en ClipVacio no pasa del preloader

Estas en el tema de Cargando swf en ClipVacio no pasa del preloader en el foro de Flash y Actionscript en Foros del Web. Hola a todos!! tengo un problema, tengo que cargar un swf en una peli principal, pero como necesito que cargue DETRÁS de algunos elementos que ...
  #1 (permalink)  
Antiguo 04/07/2006, 09:24
 
Fecha de Ingreso: noviembre-2005
Mensajes: 21
Antigüedad: 12 años
Puntos: 0
Cargando swf en ClipVacio no pasa del preloader

Hola a todos!! tengo un problema, tengo que cargar un swf en una peli principal, pero como necesito que cargue DETRÁS de algunos elementos que tengo en la principal, pensé en poner un CLipVacio en el último layer y cargar los swf's adentro , asi no tapan los elementos que les mencioné; el tema es que en vez de cargar todo con normalidad, me carga el preloader (que tengo en los 2 primeros frames de cada swf) y queda en 100% clavado y no pasa nada mas. Alguien sabe si hay confictos entre la carga de swfs en MC y los preloaders? si es asi, se les ocurre como solucionarlo O sugerirme otra manera de cargar los swf en la principal DETRAS de los elementos? GRACIAS!!!!!
  #2 (permalink)  
Antiguo 04/07/2006, 10:26
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola julian16:
El problema debe de estar en el código de la precarga.
No te entiendo con cargar DETRAS de los elementos, podrías explicarlo mejor?

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 04/07/2006, 10:53
 
Fecha de Ingreso: noviembre-2005
Mensajes: 21
Antigüedad: 12 años
Puntos: 0
Gracias por tu atención! con cargar "detras" me refiero a que tengo un dibujo en la pelicula principal que debe seguir estando visible cuando carguen los swfs externos, o sea, se debe ver el dibujo SOBRE el swf cargado. Respecto al código del preloader, debería estar bien, ya que al ejecutar el swf solo (sin cargarlo desde la principal) funciona perfecto. No le encuentro la vuelta a esto!! mil gracias!!
  #4 (permalink)  
Antiguo 04/07/2006, 11:15
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
El MC_vacío donde cargas el .swf tendría que estar debajo de la capa que contiene el dibujo.
La precarga funciona cuando ejecutas el .swf sólo, pero cuando lo cargas dentro de un MC_vacío deja de funcionar, por que de pronto en el código de carga haces referencia al _root y ese _root ya no existe al cargarse dentro de otra película, tendrías que cambiarlo por _parent.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:11.