Foros del Web » Creando para Internet » Flash y Actionscript »

Cargar en memoria un swf q se ejecutará más adelante

Estas en el tema de Cargar en memoria un swf q se ejecutará más adelante en el foro de Flash y Actionscript en Foros del Web. Hola compañeros, lo primero feilicitar a los admin por meter el vBulletin, mi preferido :P Como veis hacía tiempo q no me pasaba xD Al ...
  #1 (permalink)  
Antiguo 25/11/2002, 05:36
 
Fecha de Ingreso: noviembre-2001
Ubicación: Girona
Mensajes: 10
Antigüedad: 16 años, 1 mes
Puntos: 0
Pregunta Cargar en memoria un swf q se ejecutará más adelante

Hola compañeros, lo primero feilicitar a los admin por meter el vBulletin, mi preferido :P Como veis hacía tiempo q no me pasaba xD

Al tema. Llevo un par de semanitas con Flash, y por mis pocos conocimientos he tenido que crear lo siguiente...

principal.swf q ya tiene su preloader y tal, todo funciona correctamente.

secundaria.swf, se carga en nivel1 encima de la anterior cuando en la primera se utiliza cierto botón...
Código:
on (release) {
    loadMovieNum("secundaria.swf", 1);
}
El tema es que, pese a ocupar poquillo (unos 15kb) me queda el feo de un pequeño intervalo de tiempo hasta que se visualiza.

Y yo me preguntaba. ¿No hay una jodida manera de hacer que se guarde en caché con la primera o mientras miran la primera?

He probado mil cosas, todas lokas acorde con mis conocimientos, pero no he dado en el clavo. Entre otras he probado añadir al final de principal.swf un frame vacio, con simplemente el load... de la secundaria, para ver si así me la guardaba en caché, pero esto no es solución.

Con todo, muchas gracias por vuestra ayuda ;)
  #2 (permalink)  
Antiguo 25/11/2002, 06:12
 
Fecha de Ingreso: julio-2001
Ubicación: Barcelona
Mensajes: 922
Antigüedad: 16 años, 5 meses
Puntos: 1
Hola, q tal.

Pues la idea que comentas es buena. Coloca en el primer o segundo frame de tu pelicula un clip escondido y haz en este un loadmovie. Asi ya lo tendrás cargado cuando entres en el swf.

Saludos
  #3 (permalink)  
Antiguo 25/11/2002, 08:45
 
Fecha de Ingreso: noviembre-2001
Ubicación: Girona
Mensajes: 10
Antigüedad: 16 años, 1 mes
Puntos: 0
Mensaje

Sigo teniendo la sensación de que no se ha guardado en caché, si me lo permiten les muestro la URL aunque no miren el diseño xD, es algo temporal.

http://web.3v2.net/ingair/ca/index.php

El tema en cuestión es que al clickar sobre 'Enginyeria Consulting' se muestra un submenú, ese submenú es otra peli (tuve q hacerlo así por algunas razones...) ¿No os parece que eso no se ha cargado previamente?

Muchas gracias por tu respuesta

PD: Lo mismo haré luego con el submenú de 2.2 xD pero para no liar no lo conté, no se asusten
  #4 (permalink)  
Antiguo 25/11/2002, 08:52
 
Fecha de Ingreso: julio-2001
Ubicación: Barcelona
Mensajes: 922
Antigüedad: 16 años, 5 meses
Puntos: 1
Pues como dices, parece ser que no lo carga... Es extraño, pues si haces un loadmovie en algun frame que ya esta cargado, te tiene que cargar la movie. Lo puedes probar colocando la movie en medio de la principal, y mirar si antes de pulsar ya la ha cargado.

Saludos
  #5 (permalink)  
Antiguo 25/11/2002, 09:53
 
Fecha de Ingreso: noviembre-2001
Ubicación: Girona
Mensajes: 10
Antigüedad: 16 años, 1 mes
Puntos: 0
Oka, no lo tenía bien puesto, tenía el load... en el evento onclip(load)... del clip vacío en vez de dentro de él, pero el resultado sigue siendo el mismo.

Al ser un poco novato no estoy seguro de algo... ¿Es posible q Flash tarde tanto en hacer una transición de un frame a otro? No se si depende de ello pero yo tengo la peli a 25 fps, más q suficiente (incluso diría demasiado), pero la verdad, esto me está dando un dolor de cabeza... xD Pero claro, no puedo dejarlo así, alguien q navegue a 1kB/s se pensará q se ha colgao el Explorer xDDD

De nuevo muchas gracias colega por tu tiempo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:06.