Foros del Web » Creando para Internet » Flash y Actionscript »

Cargar sonidos online

Estas en el tema de Cargar sonidos online en el foro de Flash y Actionscript en Foros del Web. Hola! Estoy haciendo un juego en Flash y tengo problemas con "loadsound"...Cuando lo pruebo en mi equipo, de manera local, todo funciona perfectamente, y cuando ...
  #1 (permalink)  
Antiguo 20/11/2006, 03:03
 
Fecha de Ingreso: noviembre-2006
Mensajes: 4
Antigüedad: 11 años
Puntos: 0
Cargar sonidos online

Hola!
Estoy haciendo un juego en Flash y tengo problemas con "loadsound"...Cuando lo pruebo en mi equipo, de manera local, todo funciona perfectamente, y cuando pulso un boton que tiene la instruccion mysound.start(), el sonido suena bien. PERO, cuando pongo el .swf en mi web, y lo pruebo online, no se oye ningun sonido!!! Tambien he subido los mp3's, por supuesto (son cargados en tiempo de ejecucion, NO están en la libreria). Los directorios están estructurados de la siguiente manera:

-Data (esta carpeta contiene el .swf)
-Sounds (esta carpeta contiene subcarpetas con sonidos en formato mp3)

Y lo que es aún más extraño: he puesto un evento onLoad para los sonidos, para saber si se cargan OK o dan algún error...y bien, lo pruebo online (repito que en local siempre funciona bien) i veo que los sonidos cargan bien!!! Entonces, por qué no se oyen???

Muchas gracias a quien pueda ayudarme!
  #2 (permalink)  
Antiguo 20/11/2006, 12:18
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola 4GOT10:
Coloca el código completo que estás usando para cargar el sonido.

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 21/11/2006, 02:54
 
Fecha de Ingreso: noviembre-2006
Mensajes: 4
Antigüedad: 11 años
Puntos: 0
Hola Bandit gracias por responder. Uso este codigo para cargar el sonido:

Código:
nm = "crd" + String (carta_actual);
_root.GAME[nm].s.loadSound (cardso [carta_actual], false);
_root.GAME[nm].s.onLoad=function(success)
{
	if(success==true)
	{
		trace("sonido  cargado ok!");
	}
	else{
		trace("ERROR!!");
	}
}
Explico: tengo unas cartas que se llaman desde crd1 a crd35. la variable "carta_actual" la voy incrementando (esto está metido en un bucle). "cardso" es una matriz donde guardo los paths a los sonidos de cada carta. Y "GAME" es el movieclip que contiene todo el juego.
El caso, como digo, es que en local funciona perfectamente todo. Pero en web no se oyen los sonidos!

Ayudaaaaa!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:51.