Foros del Web » Creando para Internet » Flash y Actionscript »

cargar un swf de otro swf

Estas en el tema de cargar un swf de otro swf en el foro de Flash y Actionscript en Foros del Web. Hola a todos! Tengo un problema con flash que no puedo solucionar: El problema consiste en: Yo tengo un "intro.swf" que es la introduccion de ...
  #1 (permalink)  
Antiguo 05/11/2004, 11:43
 
Fecha de Ingreso: noviembre-2004
Ubicación: argentina
Mensajes: 14
Antigüedad: 13 años, 1 mes
Puntos: 0
Información cargar un swf de otro swf

Hola a todos!
Tengo un problema con flash que no puedo solucionar:
El problema consiste en:
Yo tengo un "intro.swf" que es la introduccion de la pagina. al teriminar esa intro se abre un menu con cuatro botones(voy a dar el ejemplo con uno de ellos), por ej. "services".
Al final de intro cuando se abre el menu, inserte un movieclip vacio con instancia "subnivel". Ahora viene la cuestion:
Cuando clickeo, por ej. , en "services" este boton tiene que llamar a "services.swf" por, ende, al boton services le puse este codigo
"on(release){_root.subnivel.loadMovie("services.sw f");}"
El problema es que al archivo lo carga perfectamente, pero cuando estoy en "services.swf" tengo por detras la "intro.swf"...LA CUAL NO SE VE!!! pero estan los botones del menu por debajo. se nota porque se me cambia el puntero del mouse a una manito y al hacer click me carga lo que hay abajo.
Espero que esto no sea muy confuso, en realidad es una pavada pero me esta volviendo loko. Agradeceria sus respuestas. Muchos saludos!
Baltazar
  #2 (permalink)  
Antiguo 05/11/2004, 11:54
 
Fecha de Ingreso: enero-2004
Mensajes: 8
Antigüedad: 13 años, 10 meses
Puntos: 0
Y si ponés la orden de cargar "services.swf" directamente en el boton "services"??

Es decir, sin usar el mc "subnivel". Debés ponerle al botón "services":

on (release) {
loadMovie("services.swf", 0);
}

Así services se cargará en el nivel 0 (cero), que es donde se encuentra cargado "intro.swf", y lo reemplazará descargangolo automaticamente.
  #3 (permalink)  
Antiguo 05/11/2004, 13:34
 
Fecha de Ingreso: noviembre-2004
Ubicación: argentina
Mensajes: 14
Antigüedad: 13 años, 1 mes
Puntos: 0
ya lo probe

si, ya probe. y lo que produce eso es que se me ponga la pantalla negra por unos 30seg y luego aparece "loadeng services" osea, el "services.swf"...lo puse en nivel cero para que vaya por encima y todo, pero, como digo me hace un bache entre un movie y otro. no sabes porque?
Nota: los links pesan como 700k cada uno.
  #4 (permalink)  
Antiguo 05/11/2004, 15:14
 
Fecha de Ingreso: enero-2004
Mensajes: 8
Antigüedad: 13 años, 10 meses
Puntos: 0
Al poner ambas peliculas en el nivel 0, la segunda reemplaza a la primera automaticamente, y si cada archivo pesa 700k y están en tu DD no tienen porqué tardarse tanto. Nisiquiera deberías alcanzar a ver la escena de "preloader". La formade cargar las peliculas en el mismo nivel funciona para que se vayan reemplazando una a otra, pero tambien podés utilizar la acción unLoadMovie(); para descargar un nivel determinado, (en este caso el nivel 0) y cargar "services" en otro nivel (el nivel 1, por ejemplo).
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:54.