Foros del Web » Creando para Internet » Flash y Actionscript »

Cargo un conj. de JPGs y me salen en primer plano ?!

Estas en el tema de Cargo un conj. de JPGs y me salen en primer plano ?! en el foro de Flash y Actionscript en Foros del Web. Hola gente del foro. Soy nuevo aquí como podeis comprobar. Tengo una duda con una carga de imagenes, q se cargan bien, pero no donde ...
  #1 (permalink)  
Antiguo 26/01/2004, 19:14
Avatar de lantrax  
Fecha de Ingreso: abril-2003
Ubicación: Spain is different
Mensajes: 310
Antigüedad: 14 años, 7 meses
Puntos: 0
Cargo un conj. de JPGs y me salen en primer plano ?!

Hola gente del foro. Soy nuevo aquí como podeis comprobar. Tengo una duda con una carga de imagenes, q se cargan bien, pero no donde yo quiero.

Tengo 2 capas, en una tengo un símbolo1 de clip de película. En la otra tengo un símbolo2 de clip de pelicula tb. La cosa es q el símbolo 2que se lamará en este caso "img_mc0", precarga una serie de imagenes jpg de la forma...

Código:
i=0;// la variable viene realmente de un bucle, pero para ejemplo pongo 0
porcentaje=0.15;

_parent.createEmptyMovieClip(["img_mc"+i], ++nivel);
_parent["img_mc"+i]._x=_global.origenx;
_parent["img_mc"+i]._y=_global.origeny;
_parent["img_mc"+i].loadMovie(foto[i]+".jpg","img_mc"+i);

_parent.createEmptyMovieClip(["bucle_mc"+i], ++nivel);
_parent["bucle_mc"+i].onEnterFrame = function() {
	if (por < 100) {
		por = Math.round((_parent["img_mc"+i].getBytesLoaded()/_parent["img_mc"+i].getBytesTotal())*100);
	} else {
		this.unloadMovie();
		_root["img_mc"+i]._width =_parent["img_mc"+i]._width*porcentaje;
		_root["img_mc"+i]._height =_root["img_mc"+i]._height*porcentaje;
}
}
la cosa sale bien, pero el problema es q me queda por delante del simbolo1 pese a q la capa está detrás. Ademñas intento aplicar una máscara a ese símbolo2 y no hay forma. No acepta máscara y haga lo q haga me aparece en primer plano por delante de todo lo que ponga.

Alguien sabe como puedo solucionarlo.
Estoy aplicando mál los niveles??

Una ayudita, por amor de clon

Salu2
__________________
______________________________

LaNTRaX
  #2 (permalink)  
Antiguo 26/01/2004, 19:25
Avatar de ¬...  
Fecha de Ingreso: noviembre-2003
Ubicación: Guatemala
Mensajes: 742
Antigüedad: 14 años
Puntos: 4
porque las imagenes que halas con ++nivel van a caer arriba de los niveles de las cosas que estan en las layers.. podes hacer esto: para 'subir' de nivel al simbolo1, asignale un nombre de instancia.. aqui voy a usar simbolo1
Código:
createEmptyMovieClip("nivelarriba",10000);//lo subis tan alto como necesites
simbolo1.swapDepths(nivelarriba);
__________________
'_'

...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:17.