Foros del Web » Creando para Internet » Flash y Actionscript »

clip dentro de otro Clip . Problema con boton.

Estas en el tema de clip dentro de otro Clip . Problema con boton. en el foro de Flash y Actionscript en Foros del Web. Hola. Tengo un clip vacio(FONDO) que llama a otro (INICIO). Vale. INICIO tiene un MC que contiene un boton. Este boton tiene un codigo: On(rollOver){ ...
  #1 (permalink)  
Antiguo 16/06/2006, 16:10
 
Fecha de Ingreso: junio-2006
Mensajes: 8
Antigüedad: 11 años, 6 meses
Puntos: 0
clip dentro de otro Clip . Problema con boton.

Hola.
Tengo un clip vacio(FONDO) que llama a otro (INICIO).
Vale. INICIO tiene un MC que contiene un boton. Este boton tiene un codigo:
On(rollOver){
gotoAndPlay(2)
}
on(rollOut){
gotoAndPlay(18)
}
on (press){
_root.gotoAndStop("f9");
}
En la linea principal de INICIO me va a otro menu.Hasta aqui ningun problema, epro cuando lo meto en el clip vacio FONDO no me funciona el boton.
Supongo que el fallo es en el _root.
Gracias de antemano.
  #2 (permalink)  
Antiguo 16/06/2006, 17:06
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
creo que tendrias que poner:

_root.fondo.inicio.gotoAndPlay(x);

para mandarle a un fotograma distinto en el timeline del clip INICIO


Saludos
  #3 (permalink)  
Antiguo 16/06/2006, 18:05
 
Fecha de Ingreso: junio-2006
Mensajes: 8
Antigüedad: 11 años, 6 meses
Puntos: 0
gracias, creo que ya encontré el problema.
En vez de root puse _parent y parece que funciona.
Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:38.