Foros del Web » Creando para Internet » Flash y Actionscript »

clip dinamico

Estas en el tema de clip dinamico en el foro de Flash y Actionscript en Foros del Web. Hola a todos! A ver si me podeis ayudar.. Tengo un clip dinámico cargado con attachMovie con una funcion. El problema es que una vez ...
  #1 (permalink)  
Antiguo 03/12/2004, 18:05
 
Fecha de Ingreso: marzo-2004
Mensajes: 13
Antigüedad: 13 años, 8 meses
Puntos: 0
clip dinamico

Hola a todos!
A ver si me podeis ayudar..
Tengo un clip dinámico cargado con attachMovie con una funcion. El problema es que una vez cargado lo quiero manipular tipo "quad_1.gotoAndPlay(2) " y no me hace ni caso. En cambio cuando meto el mismo código en la función si me actua. No sé como acceder al clip que está cargado, creía que solo con indicar la ruta quad_1. era suficiente. Alguien me puede ayudar?
Muchas gracias!!
  #2 (permalink)  
Antiguo 03/12/2004, 22:56
Avatar de Prince  
Fecha de Ingreso: mayo-2003
Ubicación: DF
Mensajes: 574
Antigüedad: 14 años, 7 meses
Puntos: 1
Bueno en teoría así debe ser pero solamente si lo cargaste en la línea de tiempo en la cual estas escribiendo el código. Por ejemplo:
Código:
this.attachMovie("mcQuad", "quad1", this.getNextHighestDepth()); //Lo incrustas en la línea de tiempo donde estas escribiendo
quad1.gotoAndPlay(2); //Debe funcionar
//------------------------------------------
//Ahora también lo puedes incrustar en un movieClip

clip.attachMovie("mcQuad", "quad1", clip.getNextHighestDepth());

//y para llamarlo tendrías que hacer primero referencia al clip donde lo cargaste y después lo demás

clip.quad1.gotoAndPlay(2);
__________________
- P R I N C E -
  #3 (permalink)  
Antiguo 04/12/2004, 03:55
 
Fecha de Ingreso: marzo-2004
Mensajes: 13
Antigüedad: 13 años, 8 meses
Puntos: 0
mas

Ok gracias! perfecto, ahora si puedo, pero tengo el problema que en el clip quad1 tengo un stop en el primer fotograma para no dejar ver lo que hay del 2 al 10, me salto el stop y voy directamente al fotograma 2 (quad1.gotoAndPlay(2)) y no me hace caso. Si saco el stop y lo pruebo a saco me lee bien todos los fotogramas cuando carga. El problema es este, que en teoría tendría que poder indicar el gotoAndPlay donde yo quisiera y leer a partir de ahí no?
Gracias compañeros!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:25.