Foros del Web » Creando para Internet » Flash y Actionscript »

Como cargar peliculas dentro de otras??

Estas en el tema de Como cargar peliculas dentro de otras?? en el foro de Flash y Actionscript en Foros del Web. Bueno mi caso es el siguiente. Tengo: - Una pelicula principal: principal.swf - Otra pelicula : foto.swf (la cual es cargada en la "principal" perfectamente ...
  #1 (permalink)  
Antiguo 02/03/2005, 11:01
 
Fecha de Ingreso: mayo-2004
Ubicación: Córdoba
Mensajes: 53
Antigüedad: 13 años, 7 meses
Puntos: 0
Como cargar peliculas dentro de otras??

Bueno mi caso es el siguiente.
Tengo:
- Una pelicula principal: principal.swf
- Otra pelicula : foto.swf (la cual es cargada en la "principal" perfectamente mediante, loadMovie("foto.swf",foto_mc)).

- Otra subpelicula: cuadro.swf (esta es cargada en "foto.swf", lo cual no ocurre cuando pruebo la pelicula "principal.swf".En el codigo de "foto.swf" tengo puesto:loadMovie("cuadro.swf",cuadro_mc).

Bueno,espero que me hayan comprendido y que me puedan ayudar.Creo que es problema de niveles,pero no se exactamente como resolverlo.

Alguien me ayuda????
  #2 (permalink)  
Antiguo 02/03/2005, 11:38
 
Fecha de Ingreso: diciembre-2004
Ubicación: La Rioja
Mensajes: 336
Antigüedad: 13 años
Puntos: 2
prueba a cargar la peli cuadro.swf así:

loadMovie("cuadro.swf",_root.foto_mc.cuadro_mc), es decir, pasandole la ruta completa del clip. No sé, pero tiene pinta de no encontrar la peli "cuadro.swf" desde "principal.swf".

Si no funciona, comprueba que los clips foto_mc y cuadro_mc tengan bien asignado el nombre de instancia.
  #3 (permalink)  
Antiguo 02/03/2005, 11:41
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Serguey:
Si en foto.swf tienes un MC vacío con nombre de instancia cuadro_mc y estás llamando a cuadro.swf desde un frame, el MC vacío debe de estar en una capa independiente, no es problema de niveles porque tú lo estás cargando dentro de un MC vacío.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 03/03/2005, 05:09
 
Fecha de Ingreso: mayo-2004
Ubicación: Córdoba
Mensajes: 53
Antigüedad: 13 años, 7 meses
Puntos: 0
Bueno al final he conseguio resolver el problema,aunque la verdad es que no le encuentro una explicación razonable.La cuestion es que mi pelicula "principal.swf" se encontraba en un directorio diferente de las otras.Es decir "principal.swf" estaba en un directorio y "foto.swf" y "cuadro.swf" en un directorio "Fotos" que se encontraba en el directorio en el que estaba "principal.swf".Pues bien cuando "foto.swf" hace un loadMovie para cargar en el "cuadro.swf" no hay que poner loadMovie("cuadro.swf",Cuadro_mc), sino que hay que poner << << loadMovie("Fotos/cuadro.swf",Cuadro_mc) >> >> . Con esto lo que pasa es que si pruebas la pelicula "foto.swf" de manera individual, no te cargará "cuadro.swf". Solo cuando pruebas "principal.swf" podrás ver la "cuadro.swf".

Bueno espero que con esta explicación a vosotros no os ocurra este mismo problema y gracias x intentar ayudarme.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:28.