Foros del Web » Creando para Internet » Flash y Actionscript »

¿como Le Paso Un Parametro Al Boton De Flash?

Estas en el tema de ¿como Le Paso Un Parametro Al Boton De Flash? en el foro de Flash y Actionscript en Foros del Web. Hola, saludos a todos. Estoy haciendo un botón en flash para mi web, no tiene nada del otro mundo, pero me gustaría que al pulsar ...
  #1 (permalink)  
Antiguo 23/12/2002, 05:18
Avatar de epa2  
Fecha de Ingreso: abril-2002
Ubicación: Málaga
Mensajes: 1.473
Antigüedad: 15 años, 7 meses
Puntos: 8
¿como Le Paso Un Parametro Al Boton De Flash?

Hola, saludos a todos.

Estoy haciendo un botón en flash para mi web, no tiene nada del otro mundo, pero me gustaría que al pulsar en el botón te abra mi pagina, hasta aquí todo bien, pero es que lo que no se es como ponerle en el boton el enlace con los parametros que le quiero pasar,

ahora mismo yo tengo mi página con este enlace de esta manera...

Código:
http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes")%>&a=1"><%=registros("fecha")%>
¿como seria el AS en flash con el botón?

Código:
on (release){
getURL("http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes")%>&a=1"><%=registros("fecha")%","_top">
}
Aun no lo he probado pero espero sus sabios consejos para ver si funcionaría de esa manera...

Gracias.
__________________

***Aprendiz de todo y maestro de nada***
  #2 (permalink)  
Antiguo 23/12/2002, 05:37
Avatar de epa2  
Fecha de Ingreso: abril-2002
Ubicación: Málaga
Mensajes: 1.473
Antigüedad: 15 años, 7 meses
Puntos: 8
code:--------------------------------------------------------------------------------on (release){
getURL("http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes ")%>&a=1"><%=registros("fecha")%","_top">;
}
}
--------------------------------------------------------------------------------


En esa línea me da el siguiente error, seguro que es de sintaxis pero no tengo ni papa idea..

Cita:
Escena=Escena 1, Capa=Capa 1, Fotograma=1: Línea 2: Se espera ')' o ','
¿DONDE TENGO QUE PONER LA COMA O EL PARENTESIS QUE ME FALTA???
AYUDA..

getURL("http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes ")%>&a=1"><%=registros("fecha")%","_top">;
__________________

***Aprendiz de todo y maestro de nada***
  #3 (permalink)  
Antiguo 23/12/2002, 12:15
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
Simples matematicas!

Abres 3 Parentesis y solo Cierras 2 Entonces?? falta uno .

Y si conoces la Sintaxis del GetURL que es:

getURL("Sitio.com");

y tu tienes

getURL("http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes ")%>&a=1"><%=registros("fecha")%","_top">; entonces queda asi!

getURL("http://www.misitio.com/bienvenidos.asp?visitante=<%=registros("visitantes ")%>&a=1"><%=registros("fecha")%","_top">");

Ahora yo de ASP no conosco NADA asi que no puedo decirte que tu ejemplo fucione! Pero dentro de las " " se utiliza Comillas Simples



Saludos!!
  #4 (permalink)  
Antiguo 24/12/2002, 02:26
Avatar de epa2  
Fecha de Ingreso: abril-2002
Ubicación: Málaga
Mensajes: 1.473
Antigüedad: 15 años, 7 meses
Puntos: 8
Hola TMesister, gracias por tu apreciación. ahora mismo voy a verlo.

Luego te digo.

__________________

***Aprendiz de todo y maestro de nada***
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:23.