Foros del Web » Creando para Internet » Flash y Actionscript »

con el preloader deja de andar video

Estas en el tema de con el preloader deja de andar video en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un video en la escena 2, tengo tb. dos botones play y stop para el video, además, dentro del clip que tiene el ...
  #1 (permalink)  
Antiguo 15/01/2003, 18:33
Avatar de hucasys  
Fecha de Ingreso: noviembre-2001
Ubicación: Bastante buena...
Mensajes: 816
Antigüedad: 16 años, 1 mes
Puntos: 3
con el preloader deja de andar video

Hola, tengo un video en la escena 2, tengo tb. dos botones play y stop para el video, además, dentro del clip que tiene el video, en otra capa tengo otro mc que hace un marco alrededor del video.

hasta ahí todo normal, pero cuando agrego otra escena y la pongo antes, con el código para un preloader con barra y %, deja de funcionar el video, es decir, muestra la precarga, y luego pasa a la escena 2, pero el video ya no empieza por símismo, ni tampoco con el botón play.....

qué será?

lo más extraño es que lo he hecho muchas veces antes y nunca me había pasado....

este es el código del preload....

Código:
if (_root.getBytesLoaded()>=_root.getBytesTotal()) {
_root.gotoAndPlay("inicio");
}

A = ((_root.getBytesLoaded()/_root.getBytesTotal())*100);
porcentaje = Math.round(A)+"%";

_root.barra._xscale = A;

los botones son:

on(release){
_root.video.gotoAndStop(1);
_root.video.screen.gotoAndStop(1);
}

y

on(release){
_root.video.play();
_root.video.screen.play();
}

el clip con el video tiene en el último cuadro un

gotoAndStop(1);

para que no corra como loop.


............................
  #2 (permalink)  
Antiguo 17/01/2003, 17:08
Avatar de hucasys  
Fecha de Ingreso: noviembre-2001
Ubicación: Bastante buena...
Mensajes: 816
Antigüedad: 16 años, 1 mes
Puntos: 3
no tantooo!!!

Por favor no me respondan tantooooooo!!!!!!!!
__________________
La manera en que resuelves el problema, es el problema.
ROBERT FRIPP

Última edición por hucasys; 18/01/2003 a las 10:00
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:19.