Foros del Web » Creando para Internet » Flash y Actionscript »

Copie de las Faqs y no funciona(Flash y Javascript)

Estas en el tema de Copie de las Faqs y no funciona(Flash y Javascript) en el foro de Flash y Actionscript en Foros del Web. Estimados Quiero desplegar en un frame el contenido de una página que llamo desde una peli Flash, pero no me funciona, el codigo que tengo ...
  #1 (permalink)  
Antiguo 29/01/2007, 15:38
 
Fecha de Ingreso: noviembre-2002
Ubicación: Santiago
Mensajes: 45
Antigüedad: 15 años
Puntos: 0
Exclamación Copie de las Faqs y no funciona(Flash y Javascript)

Estimados

Quiero desplegar en un frame el contenido de una página que llamo desde una peli Flash, pero no me funciona, el codigo que tengo es el siguiente:

en la peli Flash:

on (release) {
getURL("tu-pagina.html", "nombredelframe");
}

Lo probé y no despliega en el marco destino, lo despliega en un marco nuevo, osea, como si estuviera direccionado a "_blank". No se porque.

Después probé lo siguiente: quise llamar a una funcion dentro del html para llamar desde aqui la pagina que quiero mostrar, pero no hace nada.

en la peli Flash:

on (release) {
getURL("javascript:cargar('mi_pagina.htm')");
}

y en el Html:

<script type="text/javascript">
<!--
function cargar(url) {
nombredelframe.location.href=url;
}
// -->
</script>

e probado de todo, pero al hacer clic no hace nada, tengo el Flash 8.


Gracias por su ayuda.

R-Maipú
  #2 (permalink)  
Antiguo 29/01/2007, 18:18
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Copie de las Faqs y no funciona(Flash y Javascript)

Hola R-maipu:
Revisa éste link: http://www.forosdelweb.com/f16/flash-frames-457039/
sirguy dio una solución.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 01/03/2007, 12:05
Avatar de Erick_pm  
Fecha de Ingreso: abril-2004
Mensajes: 55
Antigüedad: 13 años, 7 meses
Puntos: 1
Re: Copie de las Faqs y no funciona(Flash y Javascript)

en el player 8 para que se puedas hacer uso de tu funcion añade este parametro:

<param name="allowScriptAccess" value="always"/>

Es decir que quede algo asi:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="590" height="450" id="main" align="middle">
<param name="allowScriptAccess" value="always"/>
<param name="movie" value="main.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="main.swf" quality="high" bgcolor="#ffffff" width="590" height="450" name="main" align="middle" allowScriptAccess="always" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed>
</object>

Pero por motivos que desconozco dejó de funcionar en el player 9, y es algo en la que estoy investigando.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas (incluyéndote)




La zona horaria es GMT -6. Ahora son las 12:30.