Foros del Web » Creando para Internet » Flash y Actionscript »

Cuestion de capas?

Estas en el tema de Cuestion de capas? en el foro de Flash y Actionscript en Foros del Web. Buenas, estoy creando un entorno submarino en flash, el entorno contiene una serie de ramas acuáticas por las que pasan partículas entre ellas. Para hacer ...
  #1 (permalink)  
Antiguo 01/08/2007, 06:01
 
Fecha de Ingreso: agosto-2006
Ubicación: España
Mensajes: 4
Antigüedad: 11 años, 3 meses
Puntos: 0
Cuestion de capas?

Buenas, estoy creando un entorno submarino en flash, el entorno contiene una serie de ramas acuáticas por las que pasan partículas entre ellas. Para hacer esto e importado una partícula a flash y luego he invocado el comando duplicatemovieclip para que apareciesen muchas partículas, ya sabeis como va eso..

El caso es que quiero que algunas partículas pasen por detras de unas ramas y otras por delante y lo que he hecho para eso es crear una particula en una capa superior a las de las plantas para que saliesen por delante con el comando duplicatemovieclip y hasta ahí todo bien, pero para que salgan por detrás he insertado una capa detrás de la de las ramas y pongo una partícula allí con el comando duplicatemovieclip, pero para mi sorpresa pasan dos cosas: En primer lugar solo aparecen las particulas del fondo, es decir, parecese como si el código de esta partícula se come el código de las partículas que deberían salir por delante, y segundo, ignora totalmente la capa en la que esta y directamente sale en la parte frontal por encima de todas las capas, es decir, sale delante de las plantas.

He pensado que quiza la solucion sea crear una pelicula a parte con las partículas y usar el comando loadMovieClip especificando la capa en la que saldrían.. pero sería estropear toda la jerarquía de capas que he creado y sería mucha pérdida de tiempo si sale mal. ¿Alguien podría sugerir alguna manera de solucionar el problema?

Muchísimas gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:13.