Foros del Web » Creando para Internet » Flash y Actionscript »

me da pena jejeje pero tengo un problema con una precarga

Estas en el tema de me da pena jejeje pero tengo un problema con una precarga en el foro de Flash y Actionscript en Foros del Web. Que Hongo..!! Tengo el siguiente problema.. Entre a www.cristalab.com y me daje un ejemplo de precarga, en la page sirve bien pero a la hora ...
  #1 (permalink)  
Antiguo 05/05/2004, 04:38
 
Fecha de Ingreso: abril-2004
Ubicación: México DF
Mensajes: 183
Antigüedad: 13 años, 7 meses
Puntos: 0
me da pena jejeje pero tengo un problema con una precarga

Que Hongo..!!

Tengo el siguiente problema..

Entre a www.cristalab.com y me daje un ejemplo de precarga, en la page sirve bien pero a la hora de pasarlo a mi pagina ya no sirve..!!

No entiendo porque..!! que es lo que estoy haciendo mal..??

el codigo es este:

function cargando() {
var total, cargados, porcentaje;
total = _root.getBytesTotal();
cargados = _root.getBytesLoaded();
porcentaje = Math.floor((cargados*100)/total);
porcentaje_txt.text = porcentaje + " %";
barra_mc.gotoAndStop(porcentaje);

if (cargados == total); {
clearInterval(hiloPrecarga);
play();
}
}

var hiloPrecarga = setInterval(cargando, 1);
stop();

lo pongo en el farme 21. Luego le pongo al MovieClip indicador su correspondiente nombre de instancia y los mismo al indicador de porcentaje que es un texto dinamico, pero cuando cargas la page el MovieClip indicador se queda como trabado y lo mismo el texto dinamico.
No se porke pasa eso..!!!
  #2 (permalink)  
Antiguo 05/05/2004, 05:57
 
Fecha de Ingreso: abril-2004
Ubicación: México DF
Mensajes: 183
Antigüedad: 13 años, 7 meses
Puntos: 0
Ya supe cual es el problema..!!!

Lo que pasa es que la precarga no sirve cuando es dentro de otro pelicula.

Osea yo tengo un boton que hace un LoadMovie(); y ese .swf es el que tiene la precarga pero no sirve..!!!

Alguien sabe como se puede solucionar eso..???
  #3 (permalink)  
Antiguo 05/05/2004, 20:00
 
Fecha de Ingreso: abril-2004
Ubicación: México DF
Mensajes: 183
Antigüedad: 13 años, 7 meses
Puntos: 0
entonces nadie sabe como solucionar este problema..??
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:44.