Foros del Web » Creando para Internet » Flash y Actionscript »

desesperación con rutas...una ayuda!!!

Estas en el tema de desesperación con rutas...una ayuda!!! en el foro de Flash y Actionscript en Foros del Web. vamos a ver, os cuento. resulta que tengo una peli principal (principal.swf) con menus, por cada menu cargo un swf. menu1.swf, menu2.swf y llamarlos pongo: ...
  #1 (permalink)  
Antiguo 26/09/2005, 05:28
 
Fecha de Ingreso: mayo-2005
Mensajes: 57
Antigüedad: 12 años, 7 meses
Puntos: 0
desesperación con rutas...una ayuda!!!

vamos a ver, os cuento. resulta que tengo una peli principal (principal.swf)
con menus, por cada menu cargo un swf.

menu1.swf, menu2.swf

y llamarlos pongo:
_root.menu.loadMovie("menu1.swf");// donde menu es un mc vacio

pues bien, desde esos menus cargan a su vez otros swf, donde cargo unas imagenes de fuera.

y entonces pongo en el menu1.swf:

_root.menu.menu1.loadMovie("fotos_menu1.swf")// donde menu es el mc de (principal.swf) y menu1 es un mc de (menu1.swf).

luego en el fotos_menu1.swf, cargo las fotos siguiente la ruta de:
_root.menu.menu1.fotos.loadMovie("foto1.jpg");

pues bueno, hasta ahí todo correcto hasta que utilizo los scroll de texto, que si me funcionan pero al cambiar de menu, se vuelve loca la pelicula.

estaré haciendo algo mal por culpa de las rutas??
hay un modo correcto o tendré k utilizar _parent o algo similar??
por que todo va bien si no cargo el fotos_menu1.swf


un saludo y a ver si alguien me ayuda con esto,ufffffffffff... toy desesperado.
  #2 (permalink)  
Antiguo 26/09/2005, 09:34
Avatar de El_Fantasma  
Fecha de Ingreso: marzo-2005
Ubicación: Peru
Mensajes: 481
Antigüedad: 12 años, 9 meses
Puntos: 4
entiendo que tienes un principal y dos swf donde en el principal llamas a los menus y de los menus llamas a las fotos, pero di como se vuelve loca? me imagino q crga sola las fotos o me equivoco
explicate mejor
__________________
Vida esta LLena de Retos, pero Retos A superar http://www.ideasmkt.com
  #3 (permalink)  
Antiguo 26/09/2005, 13:51
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
Pero las fotos las cargas en fotos_menu1?
Porque la ruta sería:
_root.menu.menu1.fotos_menu1.loadMovie("foto1.jpg" );

no?
Saludos
  #4 (permalink)  
Antiguo 27/09/2005, 04:35
 
Fecha de Ingreso: mayo-2005
Mensajes: 57
Antigüedad: 12 años, 7 meses
Puntos: 0
gracias

gracias, ya lo he resuelto.
resulta que en el código de las fotos tenia unas pausas, entonces al darle a play(); se volvia loca la pelicula principal, por que tenia que poner tota la ruta:
_root.menu....play();

muchas gracias por el interés.

un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:02.