Foros del Web » Creando para Internet » Flash y Actionscript »

¿Dónde está el error?

Estas en el tema de ¿Dónde está el error? en el foro de Flash y Actionscript en Foros del Web. Hola tengo un template para mostrar galerías de imágenes. Tengo el archivo .fla, el archivo .swf y los archivos .xml definidos de varias categorías de ...
  #1 (permalink)  
Antiguo 17/11/2010, 11:36
 
Fecha de Ingreso: noviembre-2010
Mensajes: 15
Antigüedad: 11 años, 8 meses
Puntos: 0
¿Dónde está el error?

Hola tengo un template para mostrar galerías de imágenes.

Tengo el archivo .fla, el archivo .swf y los archivos .xml definidos de varias categorías de imágenes.

Al arrancar carga por defecto la galería definida en Category1.xml y muestra abajo todas las imágenes (los tumbnails) y conforme selecciona te muestra la imagen en grande en el centro de la pantalla. Al pinchar sobre la imagen ésta queda atenuada y te muestra Nombre de la Galería, Título de la imagen y descripción de la misma (lo definido en el xml).

En cambio cuando cambio de categoría (por ejemplo a Category2) se trae correctamente las nuevas imágenes pero al pincharle a la imagen en grande me muestra el Título y la descripción de esa imagen correspondientes a la primera galería que cargó (Category1) haciendo caso omiso de las especificaciones del archivo Category2.xml (donde están definidos los títulos, descripciones, etc. de sus imágenes).

Me figuro que tiene que ser algún error en el código del .fla, pero es que soy totalmente novato en este mundo y no tengo ni la más remota idea de por dónde meterle mano.

Dejo aquí el código (archivo Word subido a megaupload) por si alguien lo entiende y ve dónde puede estar metida la pata. Gracias de antemano. Un saludo.


http://www.megaupload.com/?d=VD0OF6KU

Etiquetas: flash-xml
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:44.