Foros del Web » Creando para Internet » Flash y Actionscript »

easing no funciona....¿?

Estas en el tema de easing no funciona....¿? en el foro de Flash y Actionscript en Foros del Web. Hola a [email protected]: Tengo un problemilla que no acabo de solucionar con el tema del easing. Trabajando con flash 5, tengo un clip llamado "menu" ...
  #1 (permalink)  
Antiguo 05/09/2005, 12:15
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
easing no funciona....¿?

Hola a [email protected]:
Tengo un problemilla que no acabo de solucionar con el tema del easing.
Trabajando con flash 5, tengo un clip llamado "menu" que contiene un botón. Cuando clicas, el clip debería desplazarse con efecto easing a un lado de la pantalla.
Para hacer el easing uso la fórmula: _root.menu._x+=(destinox-_root.menu._x)/velocidad;
Cuando pruebo el movimiento, se "atasca"... y no llega al destino. Si elimino la velocidad, entonces se coloca correctamente en su sitio pero, claro, sin elasticidad.
Podéis ayudarme? Gracias de antemano.
Saludos
  #2 (permalink)  
Antiguo 05/09/2005, 12:31
Avatar de pulento  
Fecha de Ingreso: noviembre-2002
Ubicación: En un pequeño, helado, obscuro reino... llamado Dinamarca.
Mensajes: 1.852
Antigüedad: 15 años, 1 mes
Puntos: 1
lo estas poniendo dentro de un enterFrame...?
  #3 (permalink)  
Antiguo 05/09/2005, 13:10
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
Hola! El script lo he puesto en el botón con un on(release)...
La verdad es que estoy empezando con AS y voy un poco mareado...
  #4 (permalink)  
Antiguo 06/09/2005, 02:38
Avatar de pulento  
Fecha de Ingreso: noviembre-2002
Ubicación: En un pequeño, helado, obscuro reino... llamado Dinamarca.
Mensajes: 1.852
Antigüedad: 15 años, 1 mes
Puntos: 1
dentro del onrelease debes meterle un enterFrame ... para que la cosa funcione fluida.
Ej:
on(release){
this.onEnterFrame = function(){
_root.mc._x += (500-_root.mc._x )/4;
}
}

Salu2

.
  #5 (permalink)  
Antiguo 06/09/2005, 06:36
 
Fecha de Ingreso: marzo-2003
Ubicación: Catalunya
Mensajes: 265
Antigüedad: 14 años, 8 meses
Puntos: 2
Muchas gracias, pulento! Ahora funciona bien!
Un saludo!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:56.