Foros del Web » Creando para Internet » Flash y Actionscript »

Encontre esto pero necesito desarrollarlo mas

Estas en el tema de Encontre esto pero necesito desarrollarlo mas en el foro de Flash y Actionscript en Foros del Web. Hola Tengo que crear una presentacion en flash y que es asi: Comienza con un texto con efecto fade in y queda visible en la ...
  #1 (permalink)  
Antiguo 24/11/2006, 15:47
 
Fecha de Ingreso: noviembre-2002
Ubicación: Suecia
Mensajes: 253
Antigüedad: 15 años
Puntos: 2
Encontre esto pero necesito desarrollarlo mas

Hola
Tengo que crear una presentacion en flash y que es asi: Comienza con un texto con efecto fade in y queda visible en la pantalla, un poco mas abajo aparece una animacion (que la tengo en .swf y en .gif) esta tambien aparece con fade in pero despues de unos segundos desparece y en lugar de ella debe aparecer otro texto con fade in y que queda visible en pantalla. Ahora ustedes se preguntaran por que no inserto la animacion en .swf o .gif y cre una sola pelicula, lo hize pero la persona que creo la animacion en .swf quiere que este independiente del resto de la pelicula, no me pregunten por que. El asunto es que mirando en las faqs en contre este codigo que en parte me sirve:

"loadMovie("Animmation.swf", "");"
El problema que tengo al ejecutar este codigo es que Animmation.swf se abre en una ventana nueva y lo que yo necesito es que se abra dentro de la misma ventana en donde esta el resto de la peilcula.
Graficamente seria asi:

TEXTOTEXTOTEXTOTEXTO <--(con fade in que esta en presentacion.swf)

ANIMMATIONANIMMATIONANIMMATION<--(con fade in y out. es un .swf separado)

TEXTO2TEXTO2TEXTO2TEXTO2<--(con fade in y que debe aparecer en donde estaba la animacion una vez que esta termine qu esta en presentacion.swf)

Espero que se entienda y me den alguna ayuda.

saludos
  #2 (permalink)  
Antiguo 24/11/2006, 18:22
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Jarkaos:
Ese código que publicas está mal.
Para cargar una película externa crea un MC_vacío y al ponerlo en el escenario en el frame donde debe de cargarse le das un nombre de instancia: contenedor.
Y en ese mismo frame coloca el código así:
contenedor.loadMovie("Animmation.swf");

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 26/11/2006, 13:45
 
Fecha de Ingreso: noviembre-2002
Ubicación: Suecia
Mensajes: 253
Antigüedad: 15 años
Puntos: 2
Ya lo hize, he utilizado este codigo:

on(release) {
gotoAndPlay("Scene 2",1);
}

y todo funciona ok. Ahora viene la segunda parte. Cada escena contendra imagenes que se mostraran al hacer click sobre unas flechas, o sea cada escena contendra un menu y un poco mas abajo dos flechas (avanzar y volver). Cuando una escena comienze tendra una imagen ya cargada, como de bienvenida, y para poder avanzar a la siguiente imagen se debe hacer click en las flechas.
En esta direccion se puede ver la idea, la diferencia es que la transicion de las imagenes con fade in y out no se utilizara si no que hay que utilizar las flechas.
datanyheter. com / liza / visit . html
(hay que anteponer http : // www)
Gracias por la ayuda
  #4 (permalink)  
Antiguo 29/11/2006, 08:30
 
Fecha de Ingreso: noviembre-2002
Ubicación: Suecia
Mensajes: 253
Antigüedad: 15 años
Puntos: 2
Aqui estoy de nuevo. He avanzado un poco mas con esto del codigo y ahora estoy atascado en esto:
En la animacion estoy intentando utiliza botones para navegar por las imagenes.Las imagenes estan divididas en grupos (cada grupo esta en una escena distinta). En la escena 2 tengo 9 imagenes cada una en un frame. Un boton (que apunta hacia le derecha) funciona correctamente o sea se puede navegar por todas las imagenes y cuando llega a la ultima vuelve a comenzar si se continua presionando el boton. Pero el de la izquerda deberia hacer lo mismo salvo que hacia la izquerda el problema es que cuando llega a la primera imagen y se presiona el boton nuevamente se abre la escena 3 en vez de comenzar desde la ultima imagen.
Estos son lo codigos de los botones:
Izquerdo:
on (release) {
if (this._currentframe == 1) {
gotoAndStop (this._totalframes);
} else {
prevFrame ();
}
}

y el derecho:
on (release) {
if (this._currentframe == this._totalframes) {
gotoAndStop (1);
} else {
nextFrame ();
}
}

Alguna idea de lo que hago mal?
  #5 (permalink)  
Antiguo 29/11/2006, 09:24
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Jarkaos:
Visita mi página, allí tienes un tutor que se llama: Galería_fade_in_out, está en el botón EFECTOS.

Espero que te sea de utilidad.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:57.