Foros del Web » Creando para Internet » Flash y Actionscript »

enviar el foco al cargar mediante loadmovie

Estas en el tema de enviar el foco al cargar mediante loadmovie en el foro de Flash y Actionscript en Foros del Web. Tengo un una página principal en la que cargo otras mediante loadmovie. Hasta ahí todo perfecto. Pero... cuando se carga el nuevo flash este no ...
  #1 (permalink)  
Antiguo 08/02/2007, 12:46
 
Fecha de Ingreso: julio-2006
Mensajes: 57
Antigüedad: 11 años, 5 meses
Puntos: 0
Pregunta enviar el foco al cargar mediante loadmovie

Tengo un una página principal en la que cargo otras mediante loadmovie.
Hasta ahí todo perfecto.

Pero... cuando se carga el nuevo flash este no funciona bien con el ratón a veces logro hacer click en sus botones pero otras no.

Es como si la página cargada no recibiese el focus.

Me podeis ayudar.



PD: por supuesto el archivo cargado si lo ejecuto independientemente funciona perfectamente.
  #2 (permalink)  
Antiguo 08/02/2007, 12:50
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: enviar el foco al cargar mediante loadmovie

Hola blancorielo:
Si lo estás cargando dentro de un MC_vacío y los códigos de los botones están apuntando al _root. no funcionarán porque ese _root ya no existe al cargarlo de esa forma.
Tienes 2 opciones:
1.- Cambiar todos los _root por _parent.
2.- Cargarlo por niveles.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 08/02/2007, 12:59
 
Fecha de Ingreso: julio-2006
Mensajes: 57
Antigüedad: 11 años, 5 meses
Puntos: 0
Re: enviar el foco al cargar mediante loadmovie

Si. Es mediante un MC_vacío. La primera que carga funciona bien pero las siguientes ya no funcionan.
Concuerda con lo que dices tú?

Me puedes explicar lo de cargar por niveles?
  #4 (permalink)  
Antiguo 08/02/2007, 18:00
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: enviar el foco al cargar mediante loadmovie

En vez de usar: mc_vacio.loadMovie("archivo.swf"), usa el loadMovieNum("archivo.swf", número de nivel);

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 09/02/2007, 04:41
 
Fecha de Ingreso: julio-2006
Mensajes: 57
Antigüedad: 11 años, 5 meses
Puntos: 0
Re: enviar el foco al cargar mediante loadmovie

Esto sigue sin funcionar!!
He probado cargando mediante loadMovieNum con nivel 1 y con nivel 0.
La primera página cargada funciona bien pero las siguientes no responden correctamente al ratón.
  #6 (permalink)  
Antiguo 09/02/2007, 08:47
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: enviar el foco al cargar mediante loadmovie

Es muy complicado poderte ayudar mejor, sin ver exactamente lo que estás haciendo.
Cuelga tus archivos .fla en algún servidor para poderlos bajar y ver.

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:27.