Foros del Web » Creando para Internet » Flash y Actionscript »

Error al abrir URL

Estas en el tema de Error al abrir URL en el foro de Flash y Actionscript en Foros del Web. Saludos, soy nuevo en esto de Flash y ActionScript, verán me han encargado una página en Flash con distintas secciones, una de estas secciones se ...
  #1 (permalink)  
Antiguo 11/03/2009, 12:12
 
Fecha de Ingreso: enero-2009
Mensajes: 24
Antigüedad: 8 años, 10 meses
Puntos: 0
Error al abrir URL

Saludos, soy nuevo en esto de Flash y ActionScript, verán me han encargado una página en Flash con distintas secciones, una de estas secciones se trata de una galería.
Bien mi propósito es el siguiente, al darle a la sección de galería debería de cargar una película externa (galeria.swf).
Esta película (galeria.swf) carga las imágenes de una carpeta mediante loadMovie.
Bien llegados hasta aqui tengo el siguiente problema: desde mi película principal llamo a galeria.swf pero me manda el siguiente error: "Error al abrir URL" y me aparece la ruta de cada una de las imágenes que forman la librería, no comprendo porque no me carga las imagenes.
Cuando prueba galeria.swf me cargan sin problemas, pero cuando prueba la película principal no las carga.
Espero que puedan ayudarme, un saludo y gracias de antemano.
  #2 (permalink)  
Antiguo 11/03/2009, 13:40
Avatar de jovix777  
Fecha de Ingreso: abril-2008
Ubicación: Córdoba - Argentina
Mensajes: 151
Antigüedad: 9 años, 7 meses
Puntos: 2
Respuesta: Error al abrir URL

Fijate en el path de todos los archivos involucrados, me suena a que no esta bien la ruta.
  #3 (permalink)  
Antiguo 11/03/2009, 13:43
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Error al abrir URL

Hola RM13:
Bienvenido al Foro.
Posiblemente estás usando en esa película el código: _root, y al ser cargada dentro de un MC en la principal ese _root deja de existir.
En el primer frame de tu película galería, coloca éste código: this._lockroot = true;

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 11/03/2009, 17:06
 
Fecha de Ingreso: enero-2009
Mensajes: 24
Antigüedad: 8 años, 10 meses
Puntos: 0
Respuesta: Error al abrir URL

Hola chicos gracias por vuestra ayuda, finalmente tenia razón jovix, era un problema de la ruta, la galería la cargo en un movieclip que uso como contenedor (cont_galeria), después por código hago lo siguiente: cont_galeria.loadMovie("galeria.swf") , el problema era que en galeria.swf llamo a las fotos con esta ruta ("thumb/0" + i + ".jpg"), pero para que esto funcione en la película principal, debo pasarle esta ruta más bien ("galeria/thumb/0" + i + ".jpg") y de esta manera funciona, de todas formas aprovecho para preguntaros si es la manera correcta de cargar esta galería, es más recomendable hacerlo mediante base de datos? gracias otra vez, un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:23.