Foros del Web » Creando para Internet » Flash y Actionscript »

Error con flash y xml

Estas en el tema de Error con flash y xml en el foro de Flash y Actionscript en Foros del Web. Buenas, estoy trabajando con flash, phpy mysql. Con php consulto a la base y genero un xml dinamicamente para que flash saque la info de ...
  #1 (permalink)  
Antiguo 11/04/2006, 08:58
 
Fecha de Ingreso: julio-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.304
Antigüedad: 12 años, 5 meses
Puntos: 6
Error con flash y xml

Buenas, estoy trabajando con flash, phpy mysql. Con php consulto a la base y genero un xml dinamicamente para que flash saque la info de ahi. El tema es que a veces es como si se colgara el sistema, se congela y no andan ni los botoncitos... la unica que queda es tocar refresh. Y lo peor de todo, es que en mi maquina funciona a la perfeccion tanto local como en un servidor web... y al que no le anda, es justamente a mi cliente.

Los XML los cargo asi:

dataURL = "XML_elegir.php";
elegir_abm.ignoreWhite = true;
elegir_abm.System.useCodepage = true;
elegir_abm.onLoad = llenar_elegir;
elegir_abm.load(dataURL);

Y la funcio0n llenar_elegir, se encarga on load de tomar esos datos y distribuirlos.

Les ha pasado alguna vez? tienen idea de por que puede ser?
La verdad es que estoy con mucha bronca porque debo entregar el trabajo y como no encuentre una solucion... encima el error a mi no me ocurre y no puedo andar probando :(

Gracias si alguien me da una mano, estare enormemente agradecido :D
  #2 (permalink)  
Antiguo 11/04/2006, 09:18
Avatar de luistar  
Fecha de Ingreso: marzo-2005
Ubicación: Argentina
Mensajes: 939
Antigüedad: 12 años, 9 meses
Puntos: 0
System.useCodepage = true;
var dataURL:String = "XML_elegir.php";
var elegir_abm:XML = new XML();
elegir_abm.ignoreWhite = true;
elegir_abm.onLoad = function(cargo_correctamente){
if(cargo_correctamente) llenar_elegir();
}
elegir_abm.load(dataURL);

...
__________________
Si digo que soy mentiroso. ¿Lo soy?
  #3 (permalink)  
Antiguo 11/04/2006, 10:57
 
Fecha de Ingreso: julio-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.304
Antigüedad: 12 años, 5 meses
Puntos: 6
hummm lo he probado con eso y no ha funciondo, respecto a mi codigo es de un ejemplo de por ahi sacado en google, no pense que estuviera tan mal :S


De todas maneras ya lo he solucionado... y aunque parezca raro, reinstalando el flash player(misma version) se soluciono todo :S

Gracias igual ;)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:00.