Foros del Web » Creando para Internet » Flash y Actionscript »

Error con gotoAndPlay

Estas en el tema de Error con gotoAndPlay en el foro de Flash y Actionscript en Foros del Web. Resumo en breve el problema: Tengo una cabecera con minianimaciones al cambiar la sección. Cuando clicko en un botón envio una variable get que flash ...
  #1 (permalink)  
Antiguo 26/05/2008, 10:39
Avatar de Intrepido  
Fecha de Ingreso: diciembre-2002
Ubicación: Barcelona
Mensajes: 118
Antigüedad: 15 años
Puntos: 0
Error con gotoAndPlay

Resumo en breve el problema:
Tengo una cabecera con minianimaciones al cambiar la sección. Cuando clicko en un botón envio una variable get que flash recoge a través de Flashvars (en principio lo he comprobado y no hya problema).
Según el contenido de la variable envío con gotoAndPlay a un frame determinado.
Todos los botones funcionan en explorer perfectamente, en mozilla falla uno y no sé por qué.
Le pongo gotoAndPlay(110) y va siempre al 95. Si le pongo 65, 80, etc. (los otros botones) si funciona, pero le pongo 110, 120, etc. y no pasa del 95.

¿Alguna idea?

Código:
switch (_root.page) {
	case "main":
		play();
	break;
		
	case "empresa":
		gotoAndPlay(65);
	break;
		
	case "contacto":
		gotoAndPlay(110);
	break;
	
	case "products":
		gotoAndPlay(80);
	break;	
	
	case "calidad":
		gotoAndPlay(95);
	break;
}
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:36.