Foros del Web » Creando para Internet » Flash y Actionscript »

Error con Load Movie

Estas en el tema de Error con Load Movie en el foro de Flash y Actionscript en Foros del Web. Hola gente, tengo una consulta, aparentemente simple pero no puedo resolverlo. El asunto es este: tengo un swf base donde tengo un menu y demas ...
  #1 (permalink)  
Antiguo 30/04/2006, 02:19
 
Fecha de Ingreso: abril-2006
Mensajes: 1
Antigüedad: 11 años, 7 meses
Puntos: 0
Exclamación Error con Load Movie

Hola gente, tengo una consulta, aparentemente simple pero no puedo resolverlo. El asunto es este: tengo un swf base donde tengo un menu y demas cosas y encima quiero cargarle otra pelicula que hace un efecto sobre la foto que esta debajo una vez que uno clickea en ésta. hasta ahi vamos bien, no hay mayores problemas, en el primer frame de la peli base puse:

loadMovieNum("top_fx.swf", 1);

Cuando pongo test movie funciona perfecto, clickeo y el efecto funciona, pero cuando la cargo en el html es como que no existiera, se carga solo la primer peli. Por ahi lei que cuando hacemos un load movie se pierden las caracteristicas de botones roll over, etc de la peli cargada. Pero el tema es este, si lo exporto con el flash (Publish) el swf y el html, en el html que me genera flash SI funciona, por lo tanto no perdio sus cualidades. Ahora, si con el dreamweaver copio el codigo y lo llevo a mi html no funciona. La verdad que no se como solucionarlo asi que agradeceria su ayuda.

Desde ya muchas gracias
Saludos
  #2 (permalink)  
Antiguo 01/05/2006, 07:07
Avatar de sheshu  
Fecha de Ingreso: abril-2006
Ubicación: En too el medio
Mensajes: 160
Antigüedad: 11 años, 8 meses
Puntos: 0
Recuerda que cuando haces un loadMovie de otro swf la ruta debe ser relativa al html que contiene el primer swf. A lo mejor esta es la razón de que te funcione en el test movie y en el html no, .... no sé digo...jejje

Saludos,
__________________
sheshu ::: www.tutoriales-flash.com
  #3 (permalink)  
Antiguo 03/05/2006, 12:31
Avatar de dexter_x740  
Fecha de Ingreso: julio-2003
Ubicación: cd. obregon, Sonora
Mensajes: 246
Antigüedad: 14 años, 4 meses
Puntos: 1
lo que dice Shesu es verdad, cuando insertas un swf en un html la ruta del swf cargado debe ser relativa al html que despliega al swf principal no relativa a dicho swf principal.
__________________
[D3X73®]
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:19.