Foros del Web » Creando para Internet » Flash y Actionscript »

Error opening URL

Estas en el tema de Error opening URL en el foro de Flash y Actionscript en Foros del Web. Sera que me podrian ayudar, se programar en php pero estoy aprendiendo a crear formularios en Flash 8 y quiero capturas las variables de flash ...
  #1 (permalink)  
Antiguo 02/08/2007, 12:03
 
Fecha de Ingreso: agosto-2007
Mensajes: 1
Antigüedad: 10 años, 4 meses
Puntos: 0
Error opening URL

Sera que me podrian ayudar, se programar en php pero estoy aprendiendo a crear formularios en Flash 8 y quiero capturas las variables de flash en php pero me sale un error. Les escribo lo necesario de mi script.Gracias.

Esto tengo en el boton:
on(press){

var almacen = new LoadVars();
almacen.nombre = nom;
almacen.email = email;
almacen.empresa = empresa;

almacen.onLoad = function(){
trace("FIN DE ALTA");
};

//_root.pat es la ruta donde tengas subidos tus ficheros php
almacen.sendAndLoad(_root.pat+"registrar.php?nocac he =" +
new Date().getTime(), almacen, "GET");

}

Esto tengo en el archivo PHP:

<?PHP
$var1=$_GET_VARS[nombre];
$var2=$_GET_VARS[email];
$var3=$_GET_VARS[empresa];
echo $var1;
echo $var2;
echo $var3;
echo "&estatus=ok&";
?>

Este es el error:

FIN DE ALTA
Error opening URL
"file:///C|/Documents%20and%20Settings/JC%40rlos/Mis%20documentos/FLASH%20ARCHIVOS/Formulario%20Pendiente/undefinedregistrar.php?nocache =1186074165890?onLoad=%5Btype%20Function%5D&empres a=fsdfs&email=sfdsdfs&nombre=%3CTEXTFORMAT%20LEADI NG%3D%222%22%3E%3CP%20ALIGN%3D%22LEFT%22%3E%3CFONT %20FACE%3D%22Baskerville%20Old%20Face%22%20SIZE%3D %2263%22%20COLOR%3D%22%23FFFFFF%22%20LETTERSPACING %3D%220%22%20KERNING%3D%220%22%3Esdfsf%3C%2FFONT%3 E%3C%2FP%3E%3C%2FTEXTFORMAT%3E"
  #2 (permalink)  
Antiguo 02/08/2007, 13:37
 
Fecha de Ingreso: febrero-2007
Mensajes: 111
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: Error opening URL

hola, yo hago los envios de variables muy parecido a lo que veo aqui, solo que normalmente uso POST en lugar de GET, es decir, en el sendAndLoad pongo POST donde tu pones GET y en el php pongo:

$var1 = $HTTP_POST_VARS[nombre] ;

Creo que no es correcto el guion bajo que pones $_GET.

Por otra parte para borrar la basura tambien lo pongo mas simple :

echo "&abierto=si";

Otro detalle es este:
"registrar.php?nocac he ES ESO UN ESPACIO??

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:01.