Foros del Web » Creando para Internet » Flash y Actionscript »

Errores con loadMovie

Estas en el tema de Errores con loadMovie en el foro de Flash y Actionscript en Foros del Web. Hola gente, tengo una pelicula principal a la que le cargo otras movies. Lo que me pasa esque cuando cargo esas movies afectan a la ...
  #1 (permalink)  
Antiguo 27/07/2005, 17:47
Avatar de ostrasjo  
Fecha de Ingreso: diciembre-2004
Mensajes: 165
Antigüedad: 13 años
Puntos: 0
Errores con loadMovie

Hola gente,
tengo una pelicula principal a la que le cargo otras movies.

Lo que me pasa esque cuando cargo esas movies afectan a la principal.
Cuando en la pelicula que cargo me refiero a _root. se jode toda la página.
Lo que he tenido que hacer es meter las peliculas que cargo en un clip e ir jugando con _parent dentro de esta ya que si utilizo _root. esta pelicula que he cargado se cree que su _root es el de la principal y peta.

Es esto normal o estoy llamando mal a la película que cargo????

Un saludo y gracias
  #2 (permalink)  
Antiguo 27/07/2005, 17:53
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
es normal...

Solo existe un Root y es el de la pelicula principal, si en una pelicula secundario haces referencia a _root te estas refiriendo a la linea de tiempo de la pelicula principal..

es por eso que debes trabajar con rutas Relativas

This
_parent
  #3 (permalink)  
Antiguo 27/07/2005, 18:42
Avatar de ostrasjo  
Fecha de Ingreso: diciembre-2004
Mensajes: 165
Antigüedad: 13 años
Puntos: 0
lo tendré en cuenta a partir de ahora. Con lo cómodo que era llamar a la ruta absoluta...

Un saludo y gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:28.