Foros del Web » Creando para Internet » Flash y Actionscript »

De esas que no me explico. (Precarga)

Estas en el tema de De esas que no me explico. (Precarga) en el foro de Flash y Actionscript en Foros del Web. Que tal compañeros del foro, los saludo de nueva cuenta. Rápido y al grano. Hice una galería de fotos, todas las fotos se encuentran dentro ...
  #1 (permalink)  
Antiguo 29/07/2006, 21:37
 
Fecha de Ingreso: septiembre-2004
Ubicación: GDL, MX
Mensajes: 20
Antigüedad: 13 años, 3 meses
Puntos: 0
De esas que no me explico. (Precarga)

Que tal compañeros del foro, los saludo de nueva cuenta.

Rápido y al grano.
Hice una galería de fotos, todas las fotos se encuentran dentro del archivo SWF (nada de quererlas cargar externamente).
Pues toda la galería funciona perfectamente y he querido poner un cargador.
El código de este cargador lo uso constantemente y me funciona (es el típico, no tengo problema con el código).

Pero cuando abro la pagina, el swf se comienza a cargar sin que aparezca la animación del cargador, es como si el Internet Explorer la cargara y no el cargador del SWF.

En el primer frame he puesto un stop, en el escenario tengo un MC con este Código.

Cita:
onClipEvent (enterFrame) {
with (this._parent) {
porcentaje = Math.round((getBytesLoaded()/getBytesTotal())*100);
porcentaje_txt.text = "Cargando "+Math.round(getBytesTotal()/1024)+" Kb "+porcentaje+"%";
if(porcentaje == 100){
this._parent.gotoAndPlay(_currentframe+1);
}
}
}
Este mismo loader ya lo he usado en otras páginas como: cyranoelmusical.com


Ya intente con otro tipo de códigos como:

Cita:
en el primer frame
porcentaje = Math.floor(getBytesLoaded()/getBytesTotal()*100);
cuadrotexto.text = percentaje + "% esta cargado";
// crea un cuadro de texto dinamico llamado cuadrotexto

el segundo en blanco

el tercero tiene
if(getBytesLoaded()==getBytesTotal()){
gotoAndStop(4);
}else{
gotoAndPlay(1);
}
Y pasa lo mismo, nada. Observen ustedes mismos, esperen para que se cargue, porque el cargador no lo hace. cintli.com/gal-out.htm
(perdon por no poner las ligas, pero que no puedo hasta haber publicado 15 mensajes )

Por favor. Necesito ayuda, opciones, ideas.
  #2 (permalink)  
Antiguo 30/07/2006, 11:58
Avatar de ramon92  
Fecha de Ingreso: enero-2004
Ubicación: Lima
Mensajes: 135
Antigüedad: 13 años, 11 meses
Puntos: 8
prueba cambiando la siguiente linea
Cita:
if(_root.getBytesLoaded()==_root.getBytesTotal()){
y te aconsejo que en los 3 primeros frames no pongas ningun mc, tan solo el de precarga

1 frame // pon aca el AS de precarga y el MC de precarga
2 frame // AS de regreso al 1 frame ó
3 frame// AS de regreso al 1 frame
4 frame // tu movie
__________________
Hosting Peru.ME | Hosting para Empresas
Agencia de Publicidad Online (Enjoy the difference)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:32.