Foros del Web » Creando para Internet » Flash y Actionscript »

Estoy perdido

Estas en el tema de Estoy perdido en el foro de Flash y Actionscript en Foros del Web. A ver... estoy muy perdido...os explico: Tengo una web con seis escenas (cada escena es un apartado de la web) asi que solo cambia el ...
  #1 (permalink)  
Antiguo 21/09/2004, 06:16
 
Fecha de Ingreso: noviembre-2003
Ubicación: España->Madrid
Mensajes: 368
Antigüedad: 14 años
Puntos: 0
Pregunta Estoy perdido

A ver... estoy muy perdido...os explico:

Tengo una web con seis escenas (cada escena es un apartado de la web) asi que solo cambia el texto y fotos... pero los botones permanecen iguales!

Tengo un botón invisible con un mc detras.

En el botón invisible (el cual es el mismo en todas las escenas (kiero decir, que lo pego desde el mismo objeto de la librería)) tiene el AS siguiente (dentro del mc no de la movie general):

on (rollOver) {
tellTarget ("Links de interés") {
gotoAndStop(2);
}
}
on (rollOut) {
tellTarget ("Links de interés") {
gotoAndPlay(1);
}
}
on (release) {
gotoAndStop(61);
}
on (releaseOutside) {
tellTarget ("Links de interés") {
gotoAndStop(1);
}
}


Donde "Links de interés" es el nombre de instancia del mc que tb esta en ese mc a su vez. (ya se q es lioso... xo intentenlo porfa!).

Como ven su acen click el usuario se va al frae 61 de esa scena...

pero el problema es que si estoy en el frame 62 (por ejemplo... cualquiera mayor que 61) en vez de ir al frame 61 de esa escena... va al frame 61 de la primera escena.

QUe puedo hacer?

Muxisimas gracias de antemano
  #2 (permalink)  
Antiguo 21/09/2004, 06:32
Avatar de javiermil  
Fecha de Ingreso: agosto-2004
Mensajes: 509
Antigüedad: 13 años, 3 meses
Puntos: 2
Prueba poniendo el nombre de la escena gotoAndStop("Escena",61). Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:41.