Foros del Web » Creando para Internet » Flash y Actionscript »

Exportar sonido

Estas en el tema de Exportar sonido en el foro de Flash y Actionscript en Foros del Web. Hola a todos! Lo primero de todo: No se que haria sin vosotros!!! Y lo segundo: tengo un problema que no he encontrado solucion en ...
  #1 (permalink)  
Antiguo 23/01/2006, 06:39
 
Fecha de Ingreso: diciembre-2004
Mensajes: 10
Antigüedad: 13 años
Puntos: 0
Pregunta Exportar sonido

Hola a todos!

Lo primero de todo: No se que haria sin vosotros!!!

Y lo segundo: tengo un problema que no he encontrado solucion en las respuestas existentes.

Veran:
estoy haciendo un microsite formado de 4 peliculas swf y un preloader.
luego tengo otra pelicula donde he insertado el sonido (que debe sonar durante toda la reproduccion del microsite) y otra con un controlador para el sonido (simple, solo on y off).

en el preloader he cargado todas mis peliculas en el nivel 1 (porque una sustituye a la otra) el sonido en el 2 y el controlador del sonido en el 3 (esto lo he hecho para que esten siempre en el escenario mientras navego en el microsite en el nivel1).

el problema es que al terminar de cargar todas la peliculas y comenzar la animacion no se reproduce el sonido. (si aparece el controlados y las demas peliculas funcionan bien) pero el sonido no se carga.

este es el script que he puesto en el preloader:
var vacio:MovieClip = this.createEmptyMovieClip("vacio", 1);
var loop:MovieClip = this.createEmptyMovieClip("loop", 0);
var vacio:MovieClip;
barra._xscale = 0;
function cargador(swf) {
vacio.loadMovie(swf);
loop.onEnterFrame = function() {
total = vacio.getBytesTotal();
cargados = vacio.getBytesLoaded();
t = int((cargados*100)/total);
barra._xscale = t;
if (t>=100) {
delete loop.onEnterFrame;
barra._xscale = 0;
}
};
}
cargador("two.swf",1),
cargador("registro.swf",1),
cargador("three.swf",1),
cargador("musica.swf",2),
cargador("menuaudio.swf",3),
cargador("home.swf", 1);
if (_framesloaded) {
loadMovieNum("home.swf",1);
loadMovieNum("musica.swf",2);
loadMovieNum("menuaudio.swf",3);
};


¿es algun problema en este?

"musica.swf" es un mc donde he insertado este codigo:
Musica= new Sound ();
Musica.attachSound("Musica");
Musica.start()

"Musica"es el nombre que le he dado al sonido al vincularlo.

¿El fallo puede estar aqui?
¿hay que poner algo mas?

La verdad es que estoy bloqueada...

help!!!

muchas gracias de antemano!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:07.