Foros del Web » Creando para Internet » Flash y Actionscript »

Fallo en galeria de imagenes

Estas en el tema de Fallo en galeria de imagenes en el foro de Flash y Actionscript en Foros del Web. Hola a todos los integrantes de este foro, antes de nada me presento oficialmente en este foro ya que es mi primer mensaje. El motivo ...
  #1 (permalink)  
Antiguo 14/10/2007, 08:54
Avatar de oppjpp  
Fecha de Ingreso: octubre-2007
Mensajes: 304
Antigüedad: 10 años, 2 meses
Puntos: 2
Fallo en galeria de imagenes

Hola a todos los integrantes de este foro, antes de nada me presento oficialmente en este foro ya que es mi primer mensaje. El motivo de mi mensaje es el siguiente:

Tengo una galería de imagenes dentro de un MC, que conta de una imagén en cada fotograma y unos botones debajo para cambiar la imagen. A cada boton le he puesto la siguiente funcion:

on (press)
{
gotoAndPlay(1);
}

siendo (1) cada fotograma al que quiero enviar para que me salga la imagen.El problema se me presenta cuando le doy a previsualizacion previa, los botones funcionan perfectamente siempre y cuando comience a clickar desde el primero, si hago click por ejemplo en el 5to no pasa nada, tengo que darle al primero y apartir de ahi los demas. Sera porque tengo los botones en la misma capa???? Si alguien me puede responder se lo agradeceria ya que tengo que entregar la pagina terminada estos dias.

un saludo y gracias
  #2 (permalink)  
Antiguo 14/10/2007, 12:30
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Fallo en galeria de imagenes

Hola oppjpp:
Bienvenido al Foro.
Si tú quieres navegar fotograma en fotograma, avanzando o retrocediendo tendrias que tener 2 botones.
En la capa 1 colocar las imágenes en los fotogramas 1, 2 ,3, 4, 5, etc
En la capa 2 frame 1 los 2 botones.
Para el botón avanzar:
on(release){
nextFrame();
}
Para el botón retroceder:
on(release){
prevFrame();
}
En la capa 3 frame 1 un stop();.

Espero haberte sido de ayuda y sea eso lo que quieres hacer.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 16/10/2007, 04:44
Avatar de oppjpp  
Fecha de Ingreso: octubre-2007
Mensajes: 304
Antigüedad: 10 años, 2 meses
Puntos: 2
Re: Fallo en galeria de imagenes

Gracias Bandit por responderme, el problema es que tengo un boton para cada imagen y mediante la funcion gotoAndPlay ().... lo mando a cada frame, y el problema es que sino toco el primero los otros 7 estan inutiles, osea tengo que darle al 1ro como si este fuera el play y despues funcionan todos los demas, sabras porque??' Gracias
  #4 (permalink)  
Antiguo 16/10/2007, 11:20
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Fallo en galeria de imagenes

Utiliza el gotoAndStop(número_frame);

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:37.