Foros del Web » Creando para Internet » Flash y Actionscript »

flash, html y servidor

Estas en el tema de flash, html y servidor en el foro de Flash y Actionscript en Foros del Web. Hola. Estuve diseñando una pagina web con algunos recursillos en flash. Despues los .swf los incluia dentro del codigo html. Al subir la pagina a ...
  #1 (permalink)  
Antiguo 17/09/2006, 19:34
 
Fecha de Ingreso: enero-2002
Mensajes: 237
Antigüedad: 15 años, 10 meses
Puntos: 0
flash, html y servidor

Hola. Estuve diseñando una pagina web con algunos recursillos en flash. Despues los .swf los incluia dentro del codigo html. Al subir la pagina a la red, noto que al cargar cada pagina, se carga primero lo que esta en html y despues lo que esta en flash, dejando un espacio en blanco por un par de segundos. Hay alguna forma de evitar esto?, seguramente algo no hice bien u omiti. Las paginas en .htm pesan 4 kilos y los .swf pesan 2, 3 ,39,83 y 87kilos.
La direccion es http://www.jmcapurro.cl.nu para que noten mejor lo que estoy diciendo. Otra consulta: puede ser problema del servidor??, es un servidor gratuito (www.fateback.com).

Gracias de antemano.-
  #2 (permalink)  
Antiguo 18/09/2006, 03:32
 
Fecha de Ingreso: marzo-2004
Ubicación: Tijuana, B.C.
Mensajes: 66
Antigüedad: 13 años, 9 meses
Puntos: 0
Sonrisa Es la carga...

Hola Valaquia:

No es problema del Server, ni tu tampoco omitiste nada. Simplemente que como no usas precargas, se tardan en cargar los swf y por eso es que se ve en blanco durante unos segundos.

Tienes dos soluciones:

1. Usa precargas para que tus swf no salgan asi y en su lugar salga el "cargando".
2. Simplemente pon transparente los fondos de tus swf para que tomen el color del fondo del HTML en el que los tienes.

Para poner el fondo de los swf transparentes simplemente usa las etiquetas:

Código HTML:
<param name="wmode" value="transparent"> 
Y listo, se soluciona el asunto.

Espero que te sirva y suerte .
__________________
Que les Llueva Luz a todos!!
  #3 (permalink)  
Antiguo 19/09/2006, 11:12
 
Fecha de Ingreso: enero-2002
Mensajes: 237
Antigüedad: 15 años, 10 meses
Puntos: 0
Gracias por tu ayuda
  #4 (permalink)  
Antiguo 19/09/2006, 11:46
 
Fecha de Ingreso: septiembre-2006
Ubicación: Monterrey N.L. Mexico
Mensajes: 29
Antigüedad: 11 años, 2 meses
Puntos: 0
Mira me meti a tu link y realmente no vi problema, alomejor es poque mi internet es rapido, pero creo que solo hay una solucion para los que no tiene internet totalemente rapido.
SOLUCION:
* lo que pasa es que el SWF carga fotograma por fotograma, y los ejecuta conforme los va cargando a menos que le indiques lo contrario con un stop(); pero si en el primer fotograma de tu pelicula tienes la mayoria del peso va a tardar en verce, por lo que veo usas imagenes, bueno eso hace que la carga sea mas tardada, lo que te recomendaria es usar precargas, (preloaders) estos se ponen en el primer fotograma, para que no se vea en blanco mientras se carga la pelicula, la verdad no veo mucho problema en tu pagina porque nos son archivos muy pesados pero alomejor en un Internet lento pues si se ve un poco raro pero como te digo puedes hacer uso de precargas.
__________________________________________________ _____________
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:50.