Foros del Web » Creando para Internet » Flash y Actionscript »

Flash MX mensaje de error en escenas

Estas en el tema de Flash MX mensaje de error en escenas en el foro de Flash y Actionscript en Foros del Web. ESte mensaje de error me sale al pulsar F12 cuando quiero ver la secuencia de escenas en el navegador pero me sale todo como quiero ...
  #1 (permalink)  
Antiguo 28/03/2003, 22:03
 
Fecha de Ingreso: marzo-2003
Mensajes: 3
Antigüedad: 14 años, 8 meses
Puntos: 0
Pregunta Flash MX mensaje de error en escenas

ESte mensaje de error me sale al pulsar F12 cuando quiero ver la secuencia de escenas en el navegador pero me sale todo como quiero a la hora de ejecutarse (no veo el mensaje en el explrer sino en el mismo Flash)pero ¿porqué me sale el mensaje? ¿qué significa y cómo lo corrijo? Ya que las escenas salen como quiero, vale la pena corregirlo y buscar cual es el error? o lo dejo asi?

Gracias de antemano


Escena=Escena 1, Capa=Styles, Fotograma=45: Línea 2: Número incorrecto de parámetros; nextScene necesita exactamente 2.
nextScene(2);

Escena=Escena 2, Capa=Animar 2, Fotograma=45: Línea 2: Número incorrecto de parámetros; nextScene necesita exactamente 2.
nextScene(3);

Escena=Escena 3, Capa=Capa 2, Fotograma=100: Línea 1: Número incorrecto de parámetros; nextScene necesita exactamente 2.
stop();nextScene(4);

Escena=Escena 4, Capa=Styles, Fotograma=45: Línea 2: Número incorrecto de parámetros; nextScene necesita exactamente 2.
nextScene(7);
  #2 (permalink)  
Antiguo 28/03/2003, 23:53
Avatar de axa
axa
 
Fecha de Ingreso: enero-2002
Mensajes: 396
Antigüedad: 15 años, 10 meses
Puntos: 0
la acción nextScene no necesita parametros... es decir no debes poner

nextScene(2);
sino
nextScene();

Esta te lleva al primer frame de la siguiente escena.

Si quieres ir a una escena especifica usa gotoAndPlay o gotoAndStop,
A estas acciones le puedes indicar la escena y el frame al que quieres ir
i.e.:
gotoAndPlay(escena_x, frame_x):
Consulta la ayuda de flash para mayor info.
__________________
axa
  #3 (permalink)  
Antiguo 29/03/2003, 06:20
 
Fecha de Ingreso: marzo-2003
Mensajes: 3
Antigüedad: 14 años, 8 meses
Puntos: 0
gracias AXA, hice lo que me recomiendas, quite los el numero de escenas en los parentesis pero cuando lo hago no la pelicula se queda en la escena 1, probe con con Go andPlay y no me funciona , solo funciona cuando pongo nextScene(); con el numero de escena entre los parentesis, no se queeestoy haciendo mal............
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:12.