Foros del Web » Creando para Internet » Flash y Actionscript »

FLV con audio y video desincronizado

Estas en el tema de FLV con audio y video desincronizado en el foro de Flash y Actionscript en Foros del Web. Hola a todos, Estoy usando por primera vez el compresor flv para incluir vídeos en una película flash. El problema que tengo es que al ...
  #1 (permalink)  
Antiguo 26/07/2005, 04:25
 
Fecha de Ingreso: julio-2003
Mensajes: 15
Antigüedad: 14 años, 5 meses
Puntos: 0
FLV con audio y video desincronizado

Hola a todos,

Estoy usando por primera vez el compresor flv para incluir vídeos en una película flash. El problema que tengo es que al convertir los archivos .mov a .flv, el audio queda desincronizado. Para convertir los archivos utilizo el Flash Video Exporter desde el Quicktime v.7 Pro, y los parámetros que utilizo son:

- Encoding Method: Best (2 Pass)
- Frames per second: Same as source (también he probado de poner 25fps y luego 30fps, pero nada...)
- Limit data rate to: 230 kbits/sec
- Keyframe every: 10
- Motion Estimation: Better
- Audio Bitrate: 32 kbits/sec (Mono)
- Resize to 320x240
- Deinterlacing: Upper

A ver si un alma bondadosa puede ayudarme.

Muchísimas gracias!!!!

Última edición por falopinda; 26/07/2005 a las 05:45
  #2 (permalink)  
Antiguo 26/07/2005, 08:07
 
Fecha de Ingreso: mayo-2005
Mensajes: 83
Antigüedad: 12 años, 7 meses
Puntos: 0
y si lo pruebas directamente desde flash mx ? xD
  #3 (permalink)  
Antiguo 26/07/2005, 09:46
 
Fecha de Ingreso: julio-2003
Mensajes: 15
Antigüedad: 14 años, 5 meses
Puntos: 0
Cuando dices que lo pruebe directamente desde el Flash ¿te refieres a que importe el archivo .mov a la biblioteca y que me lo codifique entonces? ¿o que lo exporte luego?

Si es eso a lo que te refieres, ya he probado ambas cosas pero me dice que el formato del audio no es compatible y me deja la película sin sonido (cosa que con el quicktime no me pasa). Además, no quiero tener los vídeos en la biblioteca ya que son muchos los vídeos y los recojo dinámicamente de una base de datos.

Supongo que el problema viene del codificador de audio ¿que formato de audio debería pasarle al Flash Video Exporter para que me lo haga correctamente? ¿o el problema es otro?
  #4 (permalink)  
Antiguo 26/07/2005, 10:06
 
Fecha de Ingreso: julio-2003
Mensajes: 15
Antigüedad: 14 años, 5 meses
Puntos: 0
¡¡¡¡¡YA ESTAAA!!!!

¡¡Era por el formato de audio!! Los vídeos que me pasaron tendrían un formato de audio extraño y por eso me lo hacía mal. He probado de exportar el .mov a otro .mov con una codificación de audio distinta y ahora lo hace ESTUPENDAMENTEEE.

La verdad es que de sonido no entiendo mucho pero os indico lo que he puesto por si alguien se encuentra con el mismo problema y de esta forma se le arregla:

formato: Entero (Big Endian)
Frecuencia de muetsreo: 32,000 kHz
Tamaño de la muestra: 16 bits
Canales:mono
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:20.