Foros del Web » Creando para Internet » Flash y Actionscript »

Fondo blanco antes del preloader-¿por que?

Estas en el tema de Fondo blanco antes del preloader-¿por que? en el foro de Flash y Actionscript en Foros del Web. HOLA A TODOS!!! La pregunta es simple: cuando ingreso a mi pagina www.mobersa.com.ar , previo al preloader me aparece un fondo blanco y luego la ...
  #1 (permalink)  
Antiguo 30/06/2004, 16:16
Avatar de ifrit  
Fecha de Ingreso: junio-2004
Ubicación: Rosario - Argentina
Mensajes: 13
Antigüedad: 13 años, 5 meses
Puntos: 0
Fondo blanco antes del preloader-¿por que?

HOLA A TODOS!!!
La pregunta es simple: cuando ingreso a mi pagina www.mobersa.com.ar, previo al preloader me aparece un fondo blanco y luego la precarga no arranca de 0 sino del 30% (o por ahí)- ¿como puedo sacar ese fondo y que el preloader me carge desde 0%?

mi preloader esta dentro de la pelicula misma:

onClipEvent (enterFrame) {
mctotal = _root.getBytesTotal();
mcloaded = _root.getBytesLoaded();
porcentaje = Math.round((mcloaded / mctotal) * 100);
porcentajeT = porcentaje + "%";
movimiento._xscale = porcentaje;
if (porcentaje == 100) {
_root.play();
}
}
  #2 (permalink)  
Antiguo 30/06/2004, 22:32
 
Fecha de Ingreso: marzo-2004
Ubicación: Chile
Mensajes: 96
Antigüedad: 13 años, 9 meses
Puntos: 0
Lo del fondo blanco, ni idea, pero lo del preloader que comienza en el 30% me ha pasado antes. La causa era que el preloader mismo era un poco pesado (por alguna animacion, fuente embeida etc.), por lo tanto la película se demora en "cargar" la movie del preloader.

Por otro lado, podría ser que tengas algun objeto de la libreria que se esté exportando para actionscript en el primer frame. Estos también pueden demorar la aparición del preloader.
  #3 (permalink)  
Antiguo 01/07/2004, 07:57
 
Fecha de Ingreso: diciembre-2003
Ubicación: Mi casa
Mensajes: 65
Antigüedad: 14 años
Puntos: 0
Eso es tal cual lo que me pasa a mi. Tengo una peli con un scroll pane donde tengo un monton de imagenes. Una vez que agrego ese scroll pane a la biblioteca veo que el primer frame pesa como 500 kb y por eso no se ve el preloader. Tengo manera de hacer que no quede en el primer frame todo ese peso?
Gracias !
  #4 (permalink)  
Antiguo 01/07/2004, 09:37
 
Fecha de Ingreso: marzo-2004
Ubicación: Chile
Mensajes: 96
Antigüedad: 13 años, 9 meses
Puntos: 0
Si el problema viene de cuando tienes que exportar para action script elementos de la librería (que se exportan por default en el primer frame), puedes poner estos elementos (que son movies clips) en un solo frame en la scene1 justo en el frame label con el que comienza tu animación.

Con esto el preloader hace precarga también de estos elementos y no te demoran la movie después. Claro, al hacer esto, tienes que desmarcar la opción "exportar en el primer frame", cuando exportas para action script.-
  #5 (permalink)  
Antiguo 02/07/2004, 09:43
 
Fecha de Ingreso: marzo-2002
Mensajes: 20
Antigüedad: 15 años, 9 meses
Puntos: 0
Pudiste Resolver Eltema Del Fondo Blanco En La Precarga?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:56.