Foros del Web » Creando para Internet » Flash y Actionscript »

Formulario funciona en swf pero no en navegador

Estas en el tema de Formulario funciona en swf pero no en navegador en el foro de Flash y Actionscript en Foros del Web. Hola a [email protected]: Tengo un problema con un formulario en Flash MX2004. Siguiendo los manuales, he conseguido crear correctamente un formulario en flash para enviar ...
  #1 (permalink)  
Antiguo 19/01/2007, 10:05
 
Fecha de Ingreso: enero-2007
Mensajes: 2
Antigüedad: 10 años, 10 meses
Puntos: 0
Formulario funciona en swf pero no en navegador

Hola a [email protected]:

Tengo un problema con un formulario en Flash MX2004.

Siguiendo los manuales, he conseguido crear correctamente un formulario en flash para enviar correo electrónico utilizando formmail.pl

El problema es el siguiente.

Con macromedia flash, pruebo la película y va de maravillas. Me envia el correo y todo funciona perfectamente.

Pero entonces, publico la película flash para subirla al servidor, y desde allí no funciona nada. Pensaba que seria problema del servidor, pero si ejecuto la película flash exportada en el equipo local, tampoco funciona. Solo funciona desde macromedia flash con la opción probar película.

He intentado buscar soluciones al tema leyendo en internet, pero no encuentro nada que me ayude. He probado a publicarlo con distintos flash player pero sigue sin funcionar. No funciona ni en Firefox ni en explorer.

Os agradeceria mucho cualquier ayuda para solucionar este problema.
Muchas gracias de antemano.
  #2 (permalink)  
Antiguo 19/01/2007, 10:23
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Formulario funciona en swf pero no en navegador

Hola Elkitos:
Bienvenido al Foro.
Un formulario necesita el PHP para funcionar y éste es el lenguaje de parte del servidor, por lo tanto el servidor donde lo subas tiene que dar soporte a éste lenguaje y estar activado la opción enviar correo.
Dificulto que te funcione en local.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 19/01/2007, 10:35
 
Fecha de Ingreso: enero-2007
Mensajes: 2
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Formulario funciona en swf pero no en navegador

Perdona creo que no me explique bien. Cuando dije en local me refiero que el archivo esta en mi ordenador, pero hace referencia a un CGI que se llama formmail.pl que esta alojado en el servidor y funciona correctamente.

De cualquier forma el problema que tengo es que desde el proyector de flash o el propio swf, envio las variables al CGI, y me envia un correo a la dirección que le especifico, pero en cuanto ejecuto ese mismo swf (que por si solo funciona) desde un html deja de funcionar, tanto en explorer como en firefox.

El archivo Formmail esta bien configurado porque lo utilizo con otros formularios en Html, pero no me explico porque al meter el swf en un navegador deja de funcionar.

Espero que ahora se entienda mejor lo que me pasa.
Muchas gracias por la ayuda.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:31.