Foros del Web » Creando para Internet » Flash y Actionscript »

Formulario que no envia datos

Estas en el tema de Formulario que no envia datos en el foro de Flash y Actionscript en Foros del Web. Hola amigos, tengo un formulario en flash con el siguiente codigo: stop(); // -------------------------------------------------------------- // función que valida números // -------------------------------------------------------------- String.prototype.isNumbers = function() { ...
  #1 (permalink)  
Antiguo 15/07/2007, 14:48
Avatar de adexedl  
Fecha de Ingreso: julio-2005
Mensajes: 326
Antigüedad: 12 años, 5 meses
Puntos: 2
Formulario que no envia datos

Hola amigos, tengo un formulario en flash con el siguiente codigo:

stop();
// --------------------------------------------------------------
// función que valida números
// --------------------------------------------------------------
String.prototype.isNumbers = function() {
if (this.length<1) {
return false;
}
for (i=0; i<this.length; i++) {
code = this.charCodeAt(i);
if (this.charAt(i) != " " && code<48 || code>57) {
return false;
}
}
return true;
};
// --------------------------------------------------------------
// valida mails
// --------------------------------------------------------------
String.prototype.isMail = function() {
if (this.indexOf("@")>0 && this.indexOf("@") == this.lastIndexOf("@")) {
if (this.lastIndexOf(".")>this.indexOf("@")+1 && this.lastIndexOf(".")<this.length-2) {
return true;
}
}
};
// --------------------------------------------------------------
// función que limpia los campos
// --------------------------------------------------------------
function limpiar() {
nom = "";
telefono = "";
mailFrom = "";
body = "";
mensaje_error =""
}
// --
nombre.tabIndex = 1;
tel.tabIndex = 2;
mail.tabIndex = 3;
msg.tabIndex = 4;
// --
nombre.borderColor = 0xE7EFF7;
tel.borderColor = 0xE7EFF7;
mail.borderColor = 0xE7EFF7;
msg.borderColor = 0xE7EFF7;
//
nombre.onSetFocus = function() {
mensaje_error = "";
nombre.backgroundColor = 0xE7EFF7;
nombre.borderColor = 0x4A869C;
};
nombre.onKillFocus = function() {
nombre.backgroundColor = 0xFFFFFF;
nombre.borderColor = 0xE7EFF7;
};
// --
tel.onSetFocus = function() {
mensaje_error = "";
tel.backgroundColor = 0xE7EFF7;
tel.borderColor = 0x4A869C;
};
tel.onKillFocus = function() {
tel.backgroundColor = 0xFFFFFF;
tel.borderColor = 0xE7EFF7;
};
//
mail.onSetFocus = function() {
mensaje_error = "";
mail.backgroundColor = 0xE7EFF7;
mail.borderColor = 0x4A869C;
};
mail.onKillFocus = function() {
mail.backgroundColor = 0xFFFFFF;
mail.borderColor = 0xE7EFF7;
};
//
msg.onSetFocus = function() {
mensaje_error = "";
msg.backgroundColor = 0xE7EFF7;
msg.borderColor = 0x4A869C;
};
msg.onKillFocus = function() {
msg.backgroundColor = 0xFFFFFF;
msg.borderColor = 0xE7EFF7;
};
//
bEnviar.onRollOver = bLimpiar.onRollOver=function () {
this.gotoAndPlay("sobre");
};
bEnviar.onRelease = function() {
if (nom.length<1) {
mensaje_error = "Por favor introduzca su nombre";
} else if (telefono.length<1 or telefono.isnumbers() == false) {
mensaje_error = "Por favor, introduzca un teléfono de contacto";
} else if (!mail.text.isMail()) {
mensaje_error = "Por favor, introduzca e-mail válido";
} else {
loadVariablesNum("form.php", 0, "POST");
mensaje_error = "Mensaje enviado";
}
};
// --
bLimpiar.onRelease = function() {
limpiar();
};


y un archivo form.php con los siguientes datos:

<?
$to = "[email protected]";
$subject = "Consulta";
$msg = "$nom, le envía el siguiente mensaje:\n\n";
$msg .= "Teléfono: $telefono\n";
$msg .= "E-mail: $mailfrom\n";
$msg .= "Comments: $body\n";
mail($to, $subject, $msg, "From: $mailfrom");

?>


el problema es que me envia las variables, pero los datos introducidos en el formulario me los deja en blanco.

Saludos de antemano
  #2 (permalink)  
Antiguo 16/07/2007, 09:50
 
Fecha de Ingreso: marzo-2004
Mensajes: 22
Antigüedad: 13 años, 9 meses
Puntos: 0
Re: Formulario que no envia datos

Te falta recibir las variables. Tu codigo deberia ser:

<?
$to = "[email protected]";
$subject = "Consulta";
$msg = $_POST['nom'].", le envía el siguiente mensaje:\n\n";
$msg .= "Teléfono: ".$_POST['telefono']."\n";
$msg .= "E-mail:". $_POST['mailfrom']."\n";
$msg .= "Comments:". $_POST['body']."\n";
mail($to, $subject, $msg, "From:". $_POST['mailfrom']);

?>


Prueba y cuenta a ver que tal
  #3 (permalink)  
Antiguo 16/07/2007, 17:18
Avatar de adexedl  
Fecha de Ingreso: julio-2005
Mensajes: 326
Antigüedad: 12 años, 5 meses
Puntos: 2
Re: Formulario que no envia datos

Hola, no me funciona tampoco pero creo que se de donde viene el problema. Mi problema es que dicho formulario yo lo pruebo y funciona pero cuando lo meto en la película que lo quiero insertar, es decir un clip de pelicula que tiene a su vez cuatro clip de peliculas, uno dentro de otro. Pues eso, al meterlo uno dentro del otro es cuando me deja de funcionar.

Yo lo estoy copiando de uno a otro simplemente, creen que puede venir de ahí el fallo puesto que si lo utilizo normal si me funciona.

Saludos
  #4 (permalink)  
Antiguo 16/07/2007, 17:37
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: Formulario que no envia datos

deberias hacer un formulario normal en un fla nuevo y probarlo, asi solo te agobias con tanto clip anidado.
  #5 (permalink)  
Antiguo 17/07/2007, 09:09
 
Fecha de Ingreso: marzo-2004
Mensajes: 22
Antigüedad: 13 años, 9 meses
Puntos: 0
Re: Formulario que no envia datos

Revisa todas las referencias a tus variables y objetos y prueba a usar toda la ruta
_root.nombreclip.nombresubclip.nombreojeto
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:24.