Foros del Web » Creando para Internet » Flash y Actionscript »

getURL y POST

Estas en el tema de getURL y POST en el foro de Flash y Actionscript en Foros del Web. Tengo un flash dentro de un html y en un momento determinado hago un getURL a otro html (en el cual tengo un flash) llamado ...
  #1 (permalink)  
Antiguo 21/07/2004, 09:21
 
Fecha de Ingreso: julio-2004
Mensajes: 23
Antigüedad: 13 años, 5 meses
Puntos: 0
getURL y POST

Tengo un flash dentro de un html y en un momento determinado hago un getURL a otro html (en el cual tengo un flash) llamado menu.html

el codigo que uso es
getURL("menu.html", "_self", "POST");

Si embargo, no me reconoce la pagina a la que quiero ir.
Lo probe con GET en vez de POST y ahi si me la reconoce, pero el caso es que tengo que hacerlo con POST.

Alguien sabe que está mal? Puede que haya algo mal configurado en algun programa?

Gracias

zenytt
  #2 (permalink)  
Antiguo 21/07/2004, 12:27
Avatar de ¬...  
Fecha de Ingreso: noviembre-2003
Ubicación: Guatemala
Mensajes: 742
Antigüedad: 14 años
Puntos: 4
intenta esto:
Código:
getURL("menu.html", "", "POST");
__________________
'_'

...
  #3 (permalink)  
Antiguo 22/07/2004, 07:40
 
Fecha de Ingreso: julio-2004
Mensajes: 23
Antigüedad: 13 años, 5 meses
Puntos: 0
Gracias, pero me sigue sin funcionar

Alguna otra idea?
  #4 (permalink)  
Antiguo 22/07/2004, 09:28
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
No reconoce la pagina?? es decir no la encuentra? se abre el navegador y te da un Error??? Ni siquiera abre el navegador?? menu.html esta en la misma carpeta que tu SWF??

Contestanos esas preguntas para tener mas datos...

Saludos!!
  #5 (permalink)  
Antiguo 22/07/2004, 09:42
 
Fecha de Ingreso: julio-2004
Mensajes: 23
Antigüedad: 13 años, 5 meses
Puntos: 0
Edito, ahora cambie la extension de los archivos, de .html a .php y funciona bien. Alguien sabe si es que no se puede hacer getURL de html a html?

gracias

zenytt



te explico. Yo estoy usando en Windows XP el Internet Information Server en vez del Apache. En Inetpub/wwwroot/ (lo que vendria a ser el localhost) tengo una carpeta llamada "formulario" donde se encuentran los dos swf y los dos html.

La cosa es que cuando hago el getURL con "POST" me dice que la pagina no se encuentra, que la direccion es incorrecta, y sin embargo la direccion en la barra del explorador es correcta.

el getURL es
getURL("menu.html", "_self", "POST");

y cuando el getURL se ejecuta lo que me aparece en la barra del explorador es
http://localhost/formulario/menu.html
y me dice que la direccion de la pagina es incorrecta




ZENYTT

Última edición por zenytt; 28/07/2004 a las 08:26
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:23.