Foros del Web » Creando para Internet » Flash y Actionscript »

GotoAndPlay de un movie Clip dentro de otro

Estas en el tema de GotoAndPlay de un movie Clip dentro de otro en el foro de Flash y Actionscript en Foros del Web. Hola a todos: Tengo un archivo de flash que, dentro de un movie clip, carga una pelicula externa ( otro swf ). Dentro de este ...
  #1 (permalink)  
Antiguo 23/06/2005, 10:28
 
Fecha de Ingreso: junio-2005
Mensajes: 3
Antigüedad: 12 años, 5 meses
Puntos: 0
GotoAndPlay de un movie Clip dentro de otro

Hola a todos:

Tengo un archivo de flash que, dentro de un movie clip, carga una pelicula externa ( otro swf ). Dentro de este ultimo SWF tengo una funcion que al pulsar un boton carga la siguiente escena ( en concreto llamo a la funcion usando _root.NombreFuncion() ).

el caso es que si pruebo este ultimo archivo por separado, el funcionamiento del boton es correcto. el problema es que al cargar esta pelicula dentro del primer archivo, este boton ya no funciona... ¿ Donde eseta el error ?

Supongo que el problema esta en el uso de la palabra _root, que ahora hara referencia a la primera pelicula... pero como hago referencia a la pelicula cargada dentro del movie clip???

Espero haberme explicado bien...

Gracias por vuestra ayuda.
  #2 (permalink)  
Antiguo 23/06/2005, 10:38
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola juaahfer:
Ese es uno de los problemas de trabajar con escenas, es mejor trabajar con películas independientes.
1°.- En la escena 2 en el frame 1 coloca una etiqueta, por ejemplo: inicio
En el botón que llama a la escena 2 coloca el código así:
on(release){
this.gotoAndStop("inicio");
}

Espero haberte sido de ayuda
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 25/06/2005, 02:03
 
Fecha de Ingreso: junio-2005
Mensajes: 3
Antigüedad: 12 años, 5 meses
Puntos: 0
Se me olvido comentar que los botones estan en otro movie Clip, pero he puesto this._parent y me ha funcionado...

Muchas gracias por tu ayuda.. no solo me ha servido para salvar el atasco y de paso mi Web, si no que tambien me has hecho recuperar la confianza en los foros....

Muchas gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:35.