Foros del Web » Creando para Internet » Flash y Actionscript »

Hola amigos y amigas!!!

Estas en el tema de Hola amigos y amigas!!! en el foro de Flash y Actionscript en Foros del Web. Aprovecho esta oportunidad para agradecerles a todos aquellos que estan dispuestos a compartir sus experiencias y conocimientos con los menos experimentados, entre ellos Bandit, jhonnyfernando, ...
  #1 (permalink)  
Antiguo 12/09/2006, 14:42
Avatar de vec
vec
 
Fecha de Ingreso: junio-2001
Mensajes: 291
Antigüedad: 16 años, 5 meses
Puntos: 8
Hola amigos y amigas!!!

Aprovecho esta oportunidad para agradecerles a todos aquellos que estan dispuestos a compartir sus experiencias y conocimientos con los menos experimentados, entre ellos Bandit, jhonnyfernando, tigre, por solo mencionar algunos...

Por otro lado, como siempre necesito ayuda :)

Organice una web de la siguiente manera...
el archivo principal main.swf, y luego cada opcion del menu llama a otros archivos externos .swf. No se si sera de la mejor manera, y e refiero al tiempo de carga y dinamismo de la web. O conviene armar todo dentro de un mismo archivo en lugar de tener varios .swf??

Mi segunda pregunta es la siguiente, arme en otro archivo externo llamado optiondown.swf, que lo que contiene son 4 botones y cada uno llama a los mismos 4 archiivos externos *.swf del main.swf. Este minimenu lo coloco debajo, al pie de cada pagina, ya que son los botones para regresar al home, contact us, company information y servicios que ofrece la empresa. Lo curioso, es que estan colocados uno al lado del otro en diferentes capas con diferentes nombres de instancias, y el primero y el ultimo funcionan perfectamente, pero los dos del medio no. Y todos tienen el mismo codigo, solo cambia el nombre del archivo al cual llama..
El codigo es....

on (release) {

if(_root == Number(_root)){
loadMovieNum("contactus.swf",_root);
} else {
_root.loadMovie("contactus.swf");
}
}

A que se debe esto??? Desde ya muchas muchas gracias.. y si pueden darme sugerencias de mejorar la forma de organizacion, siemrpe seran bienvenidas.
__________________
[email protected]
  #2 (permalink)  
Antiguo 12/09/2006, 19:54
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola vec:
1.- Es mejor cargarlas externamente cada película que contenga las diferentes secciones de tu página, de ese modo consigues que se carguen más rápido.
2.- No entiendo porque pones los 4 botones en cada .swf cargado, simplemente ponlos en la principal y de allí cargas las 4 secciones.
Código para los botones:
on(release){
contendor.loadMovie("nombre.swf");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 12/09/2006, 23:23
Avatar de vec
vec
 
Fecha de Ingreso: junio-2001
Mensajes: 291
Antigüedad: 16 años, 5 meses
Puntos: 8
Ya lo habia intentado con ese codigo anteriormente, pero no me funciono, por eso intente de la ootra forma y funciono, claro solo el primero (home) y el segundo (contct us), losdos del medio funcionan si es que son uno de losprimeros que presionan luego ya no funciona. Eso es lo raro... Puedo enviarte el archivo a tu email para que los veas?? te enviaria solo el de contact us, que es sencillito y ahi ves lo del menu inferior. Podra ser???
Desde ya gracias...
__________________
[email protected]
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:19.