Foros del Web » Creando para Internet » Flash y Actionscript »

Hola soy nuevo-mal loadmovie de botones

Estas en el tema de Hola soy nuevo-mal loadmovie de botones en el foro de Flash y Actionscript en Foros del Web. Hola si estas leyendo esto podes ser mi salvacion, tengo un swf que carga en una parte con un loadmovie un swf que contiene 4 ...
  #1 (permalink)  
Antiguo 10/10/2008, 09:23
 
Fecha de Ingreso: agosto-2008
Mensajes: 56
Antigüedad: 9 años, 4 meses
Puntos: 0
Hola soy nuevo-mal loadmovie de botones

Hola si estas leyendo esto podes ser mi salvacion, tengo un swf que carga en una parte con un loadmovie un swf que contiene 4 botones juntos que forman una botonera y que cada uno de ello contiene cuando pasas el mouse sobre un evento.
Mi problemon es que si bien, carga ese swf "hijo" dentro del swf "padre", o sea que se lo puede ver, pero queda repitiendose continuamente la carga del evento que tenia cada boton, que supuestamente solo se deveria activar si estuviese el mouse sobre el boton.
Estos pasa sumultaneamente sobre los cuatro botones, es decir que se ve en la pantalla la botonera completa y los cuatro eventos repitiendose continuamente,
en ese momento hay un stop() en el swf"padre".
Ya intente mil cosas, busque las soluciones por mil lugares, las probe y no me dieron resultado, y ahora estoy trancado con esto.

Please si alguien me puede orientar sobre que hacer o a donde ir para informarme mas!!!!!! Gracias!!!!!

Última edición por andre1980; 10/10/2008 a las 10:01
  #2 (permalink)  
Antiguo 10/10/2008, 10:26
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Hola soy nuevo-mal loadmovie de botones

Hola andre1980:
Bienvenido al Foro.
Si los botones los haz construido dentro de un MC, en su primer frame debe de haber un stop(); de ese modo estará detenido hasta que pongas el mouse sobre él.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 12/10/2008, 13:17
 
Fecha de Ingreso: agosto-2008
Mensajes: 56
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: Hola soy nuevo-mal loadmovie de botones

...................

Última edición por andre1980; 13/10/2008 a las 11:48
  #4 (permalink)  
Antiguo 12/10/2008, 13:17
 
Fecha de Ingreso: agosto-2008
Mensajes: 56
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: Hola soy nuevo-mal loadmovie de botones

Respuesta: Hola soy nuevo-mal loadmovie de botones

--------------------------------------------------------------------------------
Gracias por la bienvenida y gracias por la ayuda, me falto por la poca experiencia

explicarlo mas detalladamente, los botones se encuentran, en "botones.swf".

Ahora mi intencion es cargarlos en "pelicula.swf" a traves de la funcion loadmovie:

Esto me significo, crear un MC vacio, darle como nombre de instancia "pelicula", y

luego en el frame agregar la accion: pelicula.loadMovie("botones.swf");


pero no carga los botones como deberia funcionar.

Ahora para entender esto te debo comentar que en el clip "botones.swf", hay

cuatro botones que contiene cada uno de ello un evento grafico (para mejorar el

aspecto visual pero que no cumplen ninguna funcion especifica)

EN EL FRAME:

_root.photo1.onEnterFrame = function() {
if (mouse_over_photo1) {
_root.photo1.nextFrame();
} else {
_root.photo1.prevFrame();
}
};

EN EL BOTON:

on (rollOver) {
_root.mouse_over_photo1 = true;
}
on (rollOut) {
_root.mouse_over_photo1 = fstartlse;
}
on (press) {gotoAndStop("Escena 4",26);
}

El tema es que cuando cargo "botones.swf" dentro de "pelicula.swf", aparecen los botones pero se repite el evento grafico una y otra vez. Este evento grafico solo deberia activarse si paso el mouse por encima del boton.

Disculpame la ignorancia de la explicacion pero por ahora es la unica forma que puedo explicarte mi problema.
Gracias nuevamente, saludos Andre
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:20.