Foros del Web » Creando para Internet » Flash y Actionscript »

En lace MC no funcionan igual en internet que en CD

Estas en el tema de En lace MC no funcionan igual en internet que en CD en el foro de Flash y Actionscript en Foros del Web. Es mi primer mensaje. Una pequeña pregunta. Para cargar un movie clip al presionar un boton movieclip para peliculas que correran en internet siempre he ...
  #1 (permalink)  
Antiguo 25/09/2008, 12:41
 
Fecha de Ingreso: septiembre-2008
Mensajes: 18
Antigüedad: 9 años, 2 meses
Puntos: 0
En lace MC no funcionan igual en internet que en CD

Es mi primer mensaje. Una pequeña pregunta. Para cargar un movie clip al presionar un boton movieclip para peliculas que correran en internet siempre he usado:

mi_movieclip.onRelease = function () {
contenedor_mc.loadMovie("pelicula.swf");
}

sin embargo al usarlo para una pelicula que corre en CD no me fucniona. Estoy colocando lo siguiente:

empresa_btn.onRelease = function () {
contenedor_mc.loadMovie("content/empresa.swf");
}

El content es la carpeta donde esta la pelicula empresa. Pense que talvez ahi estaba el error pero al probar que cargue sin necesidad de presionar algo si funciona, asi:

loadMovie("content/empresa.swf", contenedor_mc);

Que es lo que tengo mal. ALguna Idea. De antemano muchas gracias.

Norberto Hdez.
  #2 (permalink)  
Antiguo 25/09/2008, 13:30
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: En lace MC no funcionan igual en internet que en CD

Hola norbertohdez:
Bienvenido al foro.
Debería funcionar sin problemas a menos que la ruta esté mal o que en la carpeta content no esté empresa.swf.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 25/09/2008, 13:40
 
Fecha de Ingreso: septiembre-2008
Mensajes: 18
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: En lace MC no funcionan igual en internet que en CD

Bandit... Gracias ya funcionó. Lo que hice fue quitar las funciones para el boton-movieclip que estaban por fuera de este y las coloque dentro de cada boton-movieclip. Es decir cambie esto que staba fuera:

empresa_btn.onRelease = function () {
contenedor_mc.loadMovie("content/empresa.swf");
}


por esto (dentro del boton-movieclip):

this.onRelease = function(){
_root.contenedor_mc.loadMovie("content/empresa.swf");
}

...

Me imagino que el problema estaba en que al programar el boton por fuera me deba conflicto con la programación que el boton tenia por dentro para hacer el efecto de animacion rollover y roll out, que era esto:

stop();

this.onRollOver = function(){
rewind = false;
play();
}

this.onRollOut = function(){
gotoAndPlay("rollout");
}


Como vez... si fue eso?... tu que eres todo un guru

SALUDOS
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:59.