Foros del Web » Creando para Internet » Flash y Actionscript »

Llamar movie externo desde ejecutable

Estas en el tema de Llamar movie externo desde ejecutable en el foro de Flash y Actionscript en Foros del Web. Hola Tengo una presentacion hecha en Flash, en el formato SWF llama correctamente las movies (otras swf) pero en ejecutable de windows no. es factible ...
  #1 (permalink)  
Antiguo 25/11/2005, 01:57
Avatar de Microbito  
Fecha de Ingreso: octubre-2001
Ubicación: Cd. Juárez, Chihuahua, México
Mensajes: 829
Antigüedad: 16 años, 2 meses
Puntos: 6
Llamar movie externo desde ejecutable

Hola

Tengo una presentacion hecha en Flash, en el formato SWF llama correctamente las movies (otras swf) pero en ejecutable de windows no.

es factible llamar los movies externos en el ejecutable tambien?

gracias.
  #2 (permalink)  
Antiguo 25/11/2005, 10:15
Avatar de bernethe  
Fecha de Ingreso: abril-2004
Ubicación: San José, Costa Rica
Mensajes: 384
Antigüedad: 13 años, 8 meses
Puntos: 2
Pues si lo hace (de hecho, yo lo he realizado muchas veces), porqué no te pones el código para ver cuál puede ser el inconveniente
__________________
..::BERNETHE::..
  #3 (permalink)  
Antiguo 25/11/2005, 11:05
Avatar de Microbito  
Fecha de Ingreso: octubre-2001
Ubicación: Cd. Juárez, Chihuahua, México
Mensajes: 829
Antigüedad: 16 años, 2 meses
Puntos: 6
El ejecutable es de Flash Player 8.

en la linea de tiempo aparece el codigo:

Código:
loadMovieNum("contenido/salir.swf", 8);
que me llama a un movie que debe estar en toda la pelicula principal.

despues tengo unos botones que llaman a otros movie externos (7movies):

El primer boton tiene la acción:


Código:
on (release) {
	loadMovieNum("contenido/cur.swf", 1);
}
on (release) {
	unloadMovieNum(2);
	unloadMovieNum(3);
	unloadMovieNum(4);
	unloadMovieNum(5);
	unloadMovieNum(6);
	unloadMovieNum(7);
}
los demas botones tienen el mismo codigo pero llamando al movie que corresponde y al nivel de cada uno.

en SWF funciona bien pero en EXE no.
  #4 (permalink)  
Antiguo 25/11/2005, 11:46
Avatar de bernethe  
Fecha de Ingreso: abril-2004
Ubicación: San José, Costa Rica
Mensajes: 384
Antigüedad: 13 años, 8 meses
Puntos: 2
El ejecutable es de Flash Player 8.

yo lo probé y no me dió problema, realiza estos cambios para ver si te sirve (son posibles errores).

Código:
loadMovieNum("contenido/salir.swf", 1);
y aquí esto:

Código:
on (release) {
	loadMovieNum("contenido/cur.swf", 8);
	unloadMovieNum(2);
	unloadMovieNum(3);
	unloadMovieNum(4);
	unloadMovieNum(5);
	unloadMovieNum(6);
	unloadMovieNum(7);
}
a ver como te vá...
__________________
..::BERNETHE::..
  #5 (permalink)  
Antiguo 25/11/2005, 12:09
Avatar de Microbito  
Fecha de Ingreso: octubre-2001
Ubicación: Cd. Juárez, Chihuahua, México
Mensajes: 829
Antigüedad: 16 años, 2 meses
Puntos: 6
gracias bernethe, he realizado el cambio que dices y sigue sin funcionar:


pueden ver el resultado pinchando en la siguiente imagen:

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:24.