Foros del Web » Creando para Internet » Flash y Actionscript »

load movie

Estas en el tema de load movie en el foro de Flash y Actionscript en Foros del Web. hola amigos quiero hacer un boton que al pasar por ensima muestre ne un clip de pelicula una foto. Yo lo que hago es lo ...
  #1 (permalink)  
Antiguo 29/10/2005, 18:08
 
Fecha de Ingreso: junio-2004
Ubicación: La Plata
Mensajes: 190
Antigüedad: 13 años, 5 meses
Puntos: 0
load movie

hola amigos quiero hacer un boton que al pasar por ensima muestre ne un clip de pelicula una foto.
Yo lo que hago es lo siguiente, arme el boton y le puse este codigo

on(press) {
contenedor.LoadMovie("foto1.jpg");
}

Antes de esto cree en el escenario un moviclip vacio al cual le puse contenedor,
y cuando apreto el boton no me hace nada me pone error de URL.

YO el archivo este lo estoy guardando en el disco d en el mismo lugar tengo la fotos sueltas.

Alguien me puede ayudar, muchas gracias
  #2 (permalink)  
Antiguo 29/10/2005, 20:29
Avatar de richardinj  
Fecha de Ingreso: enero-2005
Ubicación: Ciber Espacio
Mensajes: 2.180
Antigüedad: 12 años, 10 meses
Puntos: 11
Quisas usas con Control+Enter para ver y ese swf se habre en otra parte...mejor exporta el SWF a la carpeta donde estan la imagenes... todos deben estar en el mismo nivel...

y usa esto en las acciones del MC "contenedor"

on(rollOver) {
this.LoadMovie("foto1.jpg");
}
  #3 (permalink)  
Antiguo 30/10/2005, 10:12
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Norbert1981:
La razón porque no te carga es que en tu código lo tienes mal escrito.
El código:loadMovie se escribe con l minúscula y tú lo estás escribiendo con L mayúscula.
EL código que tu quiere debe de estar así:
on(rollOver){
contenedor.loadMovie("foto1.jpg");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 30/10/2005, 12:11
 
Fecha de Ingreso: junio-2004
Ubicación: La Plata
Mensajes: 190
Antigüedad: 13 años, 5 meses
Puntos: 0
hola Hice lo que dijo BANDIT

Ahora me anda bien en mi computadora cuando lo subo al servidor no se ve yo tengo el swf y las foto dentro del disco D suelas,,, y anda bien
cuando lo subo al servidor pongo el swf y las fotos sueltas en la carpeta del servidor y no se ve las foto.
aca esta la botonera en esta direccion
http://www.yorshdore.com.ar/botonera.swf
yo la foto la tengo en esta direccion
http://www.yorshdore.com.ar/beto.jpg

y en el codigo le puse asi
{
contenedor.loadMovie("../beto.jpg);
}

eso anda cuando lo pruebo en la maquina es mi servidor no

( es diseño de la botonera es malo porque estoy tratando de armar el codigo por ahora)
  #5 (permalink)  
Antiguo 30/10/2005, 12:30
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Si la película y la imagen está en la misma carpeta en el servidor, el código debe de ser así:
on(rollOver){
contenedor.loadMovie("beto.jpg");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:16.