Foros del Web » Creando para Internet » Flash y Actionscript »

LoadMovie con precarga ?¿

Estas en el tema de LoadMovie con precarga ?¿ en el foro de Flash y Actionscript en Foros del Web. Hola a [email protected] de nuevo, Haber he echo un swf con un cargador que funciona. Luego he creado otro que seria el principal, este por ...
  #1 (permalink)  
Antiguo 17/03/2005, 03:51
 
Fecha de Ingreso: marzo-2005
Mensajes: 58
Antigüedad: 12 años, 9 meses
Puntos: 0
Pregunta LoadMovie con precarga ?¿

Hola a [email protected] de nuevo,

Haber he echo un swf con un cargador que funciona. Luego he creado otro que seria el principal, este por medio de un boton con la accion loadmovie para que me carge el primer swf. Lo he echo como se indica en los faq. la escena con el cargador la he echo con 2 escenas en la pimera esta el cargador y en la segunda lo que seria el contenido de la paguina. Bien, la del carador por separado funciona correctamente. Si doy, en la principal, al boton de llamada de la segunda, si le pongo en ubicacion nivel me carga bien pero en una ventana nueva, y lo que yo quiero sale poniendo destino. He aqui mi problema, solo me sale el cargador no pasa de ahi, si le quito el cargador iria todo bien, pero claro por el peso me interesaria tener el cargador.

¿Que me puede estar pasando?

Un saludo y gracias de antemano.
  #2 (permalink)  
Antiguo 17/03/2005, 04:02
pr0
 
Fecha de Ingreso: marzo-2004
Mensajes: 687
Antigüedad: 13 años, 8 meses
Puntos: 28
No te recomiendo el uso de escenas para ningún caso, y menos todavía para hacer un cargador en una escena y el contenido en otra...

La idea para la precarga con loadmovie sería:

- poner el clip donde se carga la movie con _alpha 0.
- hacer el loadmovie y seguidamente un preload normal dirigido al Clip que carga la movie.
- cuando en el preload se detecta que la movie esta totalmente cargada, cambias el _alpha del clip a 100.

Mas o menos esa es la idea, saludos.
  #3 (permalink)  
Antiguo 17/03/2005, 04:26
 
Fecha de Ingreso: marzo-2005
Mensajes: 58
Antigüedad: 12 años, 9 meses
Puntos: 0
La verdad esque no te he entendido muy bien.
En el swf principal colocaria mi mc vacio (el del Loadmovie) con alfa 0, luego el cargador ¿donde, en el que voy a cargar? (lo que seria el swf secundario) y ya donde estoy perdido del todo es en eso del poner el alfa a 100 otra vez ¿donde y como?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:33.