Foros del Web » Creando para Internet » Flash y Actionscript »

Menudo lío tengo con ActionScript3 ¿Me echáis una mano?

Estas en el tema de Menudo lío tengo con ActionScript3 ¿Me echáis una mano? en el foro de Flash y Actionscript en Foros del Web. Buenas. Como veréis soy nuevo en este foro. Tenía unas dudas y mirando por google he visto que por aquí se acercaban mucho a las ...
  #1 (permalink)  
Antiguo 19/08/2007, 12:30
 
Fecha de Ingreso: agosto-2007
Mensajes: 2
Antigüedad: 10 años, 3 meses
Puntos: 0
Exclamación Menudo lío tengo con ActionScript3 ¿Me echáis una mano?

Buenas. Como veréis soy nuevo en este foro. Tenía unas dudas y mirando por google he visto que por aquí se acercaban mucho a las respuestas que busco y como lo he visto bastante completo pues me he registrado.
El caso es que yo cuando aprendí flash me enseñaron lo básico y fue con el 5 y por aquél entonces el actionscript era el 1.0. Me enseñaron lo básico del actionscript pero claro como todo evoluciona y como no lo había tocado desde hará unos 3 años pues.... la cosa se me ha ido olvidando. Estoy acostumbrado a programar en vb.net y al retomar el actionscript me estoy armando un lío tremendo...

Bueno el caso es que tengo una "animación" que es parte de una web que estoy haciendo. Esta animación se basa en que hay un botón y al estar unos 5 segundos sobre él se muestra un contenido que se mantenía oculto. Éste, es a su vez otros 2 botones y 5 imagenes(que por cierto que componente me recomendáis para que haga de contenedor? porque las tengo que sacar de una base de datos mysql con php) bueno pues mi idea era que una vez activado esto si le doy a un botón de siguiente pues las fotos se me mueven y si le doy al otro pues se mueven a la inversa. Para esto había puesto 3 q se ven y 2 ocultas. Así cuando se vayan moviendo la primera se irá escondiendo y la útlima se mostrará y entonces cuando la primera esté escondida la envío a la última posición y bueno ya me entedéis se crea un loop.
Bueno pues resulta que toda la idea se me ha ido a la mierda por culpa de los temporizadores porque no acabo de pillar la idea que explicáis en otros post referentes al tiempo porque en vb.net uno para esto tiene un control que lo toquetea pero aquí la cosa sale de la nada.... y tampoco puedo meterle el rollover al botón. El flash no me deja . Le voy a poner al botón y no me deja escribir el actionscript y si lo pongo en la capa hago lo de vuestra faq de _root.boton.rollover..... y siempre me tira error. Si pongo el actionscript 1 me manejo un poco pero esq entonces adiós a los contenedores de las imagenes porque requieren actionscript3 ..... total un auténtico lio. ¿Seríais tan amables de explicarmelo con más detalle todo esto? Bueno y si conocéis alguna cosa así y no es mucha molestia pasarmelo.... ¿me lo podríais pasar? :D jeje

Muchas gracias por vuestra ayuda y perdón por el tostón. Por cierto por si no os acabáis de enterar de lo que quiero hacer aquí os dejo un croquis:
http://img248.imageshack.us/my.php?image=croquisph8.png
  #2 (permalink)  
Antiguo 19/08/2007, 12:49
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Menudo lío tengo con ActionScript3 ¿Me echáis una mano?

Hola Carvan:
Bienvenido al Foro.
Porque no te das una vuelta por la Ayuda del Flash, allí tienes la explicación de los códigos del ActionScript y con ejemplos.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 19/08/2007, 15:34
 
Fecha de Ingreso: agosto-2007
Mensajes: 2
Antigüedad: 10 años, 3 meses
Puntos: 0
Re: Menudo lío tengo con ActionScript3 ¿Me echáis una mano?

Ay vá. En eso no había caido. Y mira que para el vb.net lo busco antes de buscar en google. Bueno ahora lo miro. Si tengo alguna duda ya volveré a contestar en este post
  #4 (permalink)  
Antiguo 22/08/2007, 09:44
Avatar de pituu2  
Fecha de Ingreso: abril-2004
Ubicación: paraná entre rios
Mensajes: 274
Antigüedad: 13 años, 7 meses
Puntos: 0
Re: Menudo lío tengo con ActionScript3 ¿Me echáis una mano?

otra cosa según tengo entendido el "_root" no se usa más !
__________________
pituu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:32.