Foros del Web » Creando para Internet » Flash y Actionscript »

Mi scroll de botones falla

Estas en el tema de Mi scroll de botones falla en el foro de Flash y Actionscript en Foros del Web. Hola a todos cree un scroll de botones que sirve para activar clips de pelicula.El codigo de uno de los botones de mi scroll de ...
  #1 (permalink)  
Antiguo 17/12/2004, 14:40
 
Fecha de Ingreso: diciembre-2004
Ubicación: Cancun QRoo
Mensajes: 218
Antigüedad: 13 años
Puntos: 0
Mi scroll de botones falla

Hola a todos cree un scroll de botones que sirve para activar clips de pelicula.El codigo de uno de los botones de mi scroll de botones es:

on(press)
{
_root.setProperty(fotolineas,_visible,0);
_root.setProperty(textlin,_visible,1);
_root.textlin.play();
}

fotolineas el el nombre de la instancia de un clip de pelicula que antes era una foto.

textlin igual es un clip de pelicula que antes era un texto con scroll.

Se supone que lo que yo quiero hacer es que cuando presione el boton se quite la foto(MC) y aparesca el texto(MC) .

textlin si aparece pero fotolineas no desaparece.

Ya cheque los nombres de las instancias ..... son las correctas.

que mas....aaaa si la foto aparece al entrar al fotograma tal vez sea eso....la verdad no se.


espero haberme explicado sino pos les mando todo el.fla para que le echen un vistazo y me digan como va quedando mi fla.

Última edición por MagodeOz; 17/12/2004 a las 14:43
  #2 (permalink)  
Antiguo 17/12/2004, 15:24
cmc
 
Fecha de Ingreso: febrero-2003
Ubicación: Capital
Mensajes: 1.317
Antigüedad: 14 años, 10 meses
Puntos: 1
¿Estas seguro que ambas instancias son correctas y estan en el root?
__________________
Claudio Caldareri
diseñador Multimedial
www.disemedios.com.ar
  #3 (permalink)  
Antiguo 17/12/2004, 16:16
Avatar de goc00  
Fecha de Ingreso: enero-2002
Ubicación: 000's DiMensiOn
Mensajes: 979
Antigüedad: 15 años, 10 meses
Puntos: 3
Saludos...

Al parecer es error de sintaxis... ese _root debería ir dentro de los parámetros de la función setProperty, prueba utlizando este código:

Código:
on (press) { 
   _root.fotolineas._visible=0;
   _root.textlin._visible=1;
   _root.textlin.play();
}
  #4 (permalink)  
Antiguo 19/12/2004, 17:36
 
Fecha de Ingreso: diciembre-2004
Ubicación: Cancun QRoo
Mensajes: 218
Antigüedad: 13 años
Puntos: 0
si estoy seguro que las instancias estan en root y que son los nombres correctos voy a probar el codigo muchas gracias

Última edición por MagodeOz; 19/12/2004 a las 17:40
  #5 (permalink)  
Antiguo 21/12/2004, 12:17
 
Fecha de Ingreso: diciembre-2004
Ubicación: Cancun QRoo
Mensajes: 218
Antigüedad: 13 años
Puntos: 0
Muchas gracias a lo que me respondieron pero el primer lugar se lo llevo goc00 felicidades funciono el codigo.... el root iba en el nombre de la instancia

bye.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:36.