Foros del Web » Creando para Internet » Flash y Actionscript »

mozilla firefox y flashvars

Estas en el tema de mozilla firefox y flashvars en el foro de Flash y Actionscript en Foros del Web. Hola bueno tengo un problema lo que pasa que tengo unos banners en flash los cuales utilizo con el sistema de banners de phpnuke claro ...
  #1 (permalink)  
Antiguo 19/06/2004, 23:11
Avatar de frogx3  
Fecha de Ingreso: abril-2003
Ubicación: Merida, Yucatan
Mensajes: 79
Antigüedad: 14 años, 8 meses
Puntos: 0
mozilla firefox y flashvars

Hola bueno tengo un problema lo que pasa que tengo unos banners en flash los cuales utilizo con el sistema de banners de phpnuke claro este modificado para que sean contados sus clicks... esta es la modificacion la cual envia la variable imageurl al archivo banners.swf

Código:
echo "<object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0\" width=\"$flash_width\" height=\"$flash_height\">";
echo "<param name=\"movie\" value=\"banners.swf\">";
echo "<param name=\"quality\" value=\"high\">";
echo "<param name=FlashVars value=\"imageurl=$imageurl&bid=$bid\">";
echo "<embed src=\"banners.swf\" quality=\"high\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" type=\"application/x-shockwave-flash\" width=\"$flash_width\" height=\"$flash_height\">";
echo "</embed>";
echo "</object>";
y aqui esta la manera con la cual el archivo banners.swf carga el banner con un loadMovie..

Código:
loadMovie(imageurl, "banner");
El problema no se donde este...porque en el internet explorer de windows funciona a la perfeccion pero en el mozilla firefox no funciona en absoluto...como que la variable no la recibe el archivo...y n ose porque...

bueno espero me puedan ayudar...y muchas gracias de antemano.,...
  #2 (permalink)  
Antiguo 21/06/2004, 15:28
Avatar de GeoAvila
Colaborador
 
Fecha de Ingreso: diciembre-2003
Ubicación: Antigua Guatemala
Mensajes: 4.032
Antigüedad: 14 años
Puntos: 53
podría ser a la version de html que reconoce tu Mozilla, deberías bajarte una version mas reciente,,, o bien trasladar tu pregunta a los fors de linux... u otra opcion es el netscape. 6.0 o 7.1

nos vemos...
__________________
* Antes de preguntar lee las FAQ, y por favor no hagas preguntas en las FAQ
Sitio http://www.geoavila.com twitter: @GeoAvila
  #3 (permalink)  
Antiguo 31/08/2004, 18:07
 
Fecha de Ingreso: enero-2003
Ubicación: Valdivia
Mensajes: 5
Antigüedad: 14 años, 10 meses
Puntos: 0
hola!

bueno a mi me esta presentando el mismo problema y peor aun que tambien sucede lo mismo con NETSCAPE 7.02
  #4 (permalink)  
Antiguo 13/09/2004, 17:41
Avatar de frogx3  
Fecha de Ingreso: abril-2003
Ubicación: Merida, Yucatan
Mensajes: 79
Antigüedad: 14 años, 8 meses
Puntos: 0
Hola el que hizo la pregunta les reponde despues de haber buscado no recuerdo por donde consegui ya hace bastante tiempo la respuesta si se dan cuenta cuando ponen el codigo que muestra la pelicula ponen:

Código:
echo "<object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0\" width=\"$flash_width\" height=\"$flash_height\">";
echo "<param name=\"movie\" value=\"banners.swf\">";
echo "<param name=\"quality\" value=\"high\">";
echo "<param name=FlashVars value=\"imageurl=$imageurl&bid=$bid\">";
echo "<embed src=\"banners.swf\" quality=\"high\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" type=\"application/x-shockwave-flash\" width=\"$flash_width\" height=\"$flash_height\">";
echo "</embed>";
echo "</object>";
y de esa manera les da el problema que bajo netscape o mozilla no se veran sus banners el problema se resuelve asi deben declarar las variables de la pelicula en el embed:


Código:
echo "<object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0\" width=\"$flash_width\" height=\"$flash_height\">";
echo "<param name=\"movie\" value=\"banners.swf\">";
echo "<param name=\"quality\" value=\"high\">";
echo "<param name=FlashVars value=\"imageurl=$imageurl&bid=$bid\">";
echo "<embed src=\"banners.swf\" FlashVars=\"imageurl=$imageurl&bid=$bid\" quality=\"high\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" type=\"application/x-shockwave-flash\" width=\"$flash_width\" height=\"$flash_height\">";
echo "</embed>";
echo "</object>";
igual si no quieren mostrar el menu de flash que no funciona esta opcion en firefox si se la añades a tu pelicula con el fscommand simplemente en el embes ponen

menu=false
y otros como
allowscale=false
y otros que no recuerdo ahora.....


bueno espero haberles ayudado cualquier otra duda me dicen que ya me han ayudado mucho por aqui y tambien quiero poner mi granito de arena....
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:53.