Foros del Web » Creando para Internet » Flash y Actionscript »

ME MUERO...!!!...Cargando Variables...

Estas en el tema de ME MUERO...!!!...Cargando Variables... en el foro de Flash y Actionscript en Foros del Web. Necesito ayuda... Estoy tratando de obtener el valor de un par de variables que se encuentran en un TXT... Mi TXT se llama info.txt y ...
  #1 (permalink)  
Antiguo 11/02/2004, 14:37
Avatar de eldandy  
Fecha de Ingreso: diciembre-2002
Mensajes: 18
Antigüedad: 15 años
Puntos: 0
Pregunta ME MUERO...!!!...Cargando Variables...

Necesito ayuda...

Estoy tratando de obtener el valor de un par de variables que se encuentran en un TXT...

Mi TXT se llama info.txt y contiene lo siguiente:

&total_imgs=12&titulo=texto&

Despues en el primer fotograma de mi pelicula principal pongo el siguiente código:

_global.total_imgs;
_global.titulo;

loadVariables("info.txt", 0);

Esta es una de las muchas variantes que encontre en este foro para cargar texto desde un TXT...

El caso es que al cargar la variable no me da ningun valor y al darle un TRACE a la variable me marca UNDEFINED...

Espero que alguienpueda ayudarme...ya me di de topes en la pared tratando de resolver esto y no sale...jeje...

Gracias de antemano...
  #2 (permalink)  
Antiguo 11/02/2004, 14:56
Avatar de ¬...  
Fecha de Ingreso: noviembre-2003
Ubicación: Guatemala
Mensajes: 742
Antigüedad: 14 años
Puntos: 4
al txt:
Código:
total_imgs=12&titulo=texto
en el frame, para cargar los datos:
Código:
createEmptyMovieClip("contenedor",10);
loadVariables("info.txt",contenedor);
para leer las variables:
Código:
trace(contenedor.total_imgs);
__________________
'_'

...
  #3 (permalink)  
Antiguo 11/02/2004, 21:32
Avatar de eldandy  
Fecha de Ingreso: diciembre-2002
Mensajes: 18
Antigüedad: 15 años
Puntos: 0
Noup... :'(

No...me sigue marcando UNDEFINED al darle TRACE...

No se si sera algo que tenga que ver con mi instalacion de Flash...aunque ya lo probe en otra PC y hace lo mismo...gracias de todas formas...espero que alguien pueda sacarme de este agujero donde estoy metido...por favor...!!!...
  #4 (permalink)  
Antiguo 16/02/2004, 12:42
Avatar de eldandy  
Fecha de Ingreso: diciembre-2002
Mensajes: 18
Antigüedad: 15 años
Puntos: 0
De acuerdo Lo logre...!!!

Por fin despues de tanto darle vueltas a mi codigo resulto ser algo de lo mas simple pero que yo desconocia...

El archivo de texto lo tenia en una carpeta que estaba dentro del directorio raiz de mi pelicula...

Al indicarle el path del archivo de texto lo hacia asi:

"\carpeta\archivo.txt"

pero debe ser asi:

"carpeta\archivo.txt"

Sin la primera diagonal ...Gracias de todas formas...Este foro es la neta ayuda muchisimo...SALUDOS...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:14.